p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 5

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 165

  1. CVE-2019-14817

    High · CVSS 7.3EPSS 2.02%Fix available

    CVE-2019-14817

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdfexectoken and other procedures where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated
  2. CVE-2019-14811

    High · CVSS 7.3EPSS 3.75%Fix available

    CVE-2019-14811

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdf_hook_DSC_Creator procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated
  3. CVE-2017-15652

    Medium · CVSS 5.5EPSS 1.3%Fix available

    CVE-2017-15652

    Artifex Ghostscript 9.22 is affected by: Obtain Information. The impact is: obtain sensitive information. The component is: affected source code file, affected function, affected executable, affected libga (imagemagick used that). The attack vector is: Someone must open a postscript file though ghostscript. Because of imagemagick also use libga, so it was affected as well.

    • Update to 9.25~dfsg-1
    Published Updated
  4. CVE-2019-3839

    High · CVSS 7.3EPSS 1.76%Fix available

    CVE-2019-3839

    It was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable.

    • Update to 9.27~dfsg-1
    Published Updated
  5. CVE-2018-19134

    High · CVSS 7.8EPSS 2.87%Fix available

    CVE-2018-19134

    In Artifex Ghostscript through 9.25, the setpattern operator did not properly validate certain types. A specially crafted PostScript document could exploit this to crash Ghostscript or, possibly, execute arbitrary code in the context of the Ghostscript process. This is a type confusion issue because of failure to check whether the Implementation of a pattern dictionary was a structure type.

    • Update to 9.26~dfsg-1
    Published Updated
  6. CVE-2018-16802

    High · CVSS 7.8EPSS 2.09%Fix available

    CVE-2018-16802

    An issue was discovered in Artifex Ghostscript before 9.25. Incorrect "restoration of privilege" checking when running out of stack during exception handling could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction. This is due to an incomplete fix for CVE-2018-16509.

    • Update to 9.25~dfsg-1
    Published Updated
  7. CVE-2018-16585

    High · CVSS 7.8EPSS 1.72%Fix available

    CVE-2018-16585

    An issue was discovered in Artifex Ghostscript before 9.24. The .setdistillerkeys PostScript command is accepted even though it is not intended for use during document processing (e.g., after the startup phase). This leads to memory corruption, allowing remote attackers able to supply crafted PostScript to crash the interpreter or possibly have unspecified other impact. Note: A reputable source believes that the CVE is potentially a duplicate of CVE-2018-15910 as explained in Red Hat bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=1626193)

    • Update to 9.25~dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →