p PatchFirst

PatchFirst · Latest vulnerabilities

openclaw 2026.5.7: known vulnerabilities · Page 2

Known vulnerabilities affecting openclaw 2026.5.7: 32. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 32

  1. CVE-2026-53820

    Medium · CVSS 6.9EPSS 0.09%Fix available

    OpenClaw < 2026.5.12 - Exec Denylist Bypass in Bundle MCP Loopback Session Spawn

    OpenClaw before 2026.5.12 contains an exec denylist bypass vulnerability in the bundle MCP loopback session-spawn path that allows authenticated callers to bypass intended command restrictions. Attackers can reach the affected bundled MCP session-spawn path to start sessions with broader command reach than intended.

    • Update to 2026.5.12
    Published Updated
  2. CVE-2026-53819

    High · CVSS 8.7EPSS 0.3%Fix available

    OpenClaw < 2026.5.27 - Arbitrary Homebrew Executable Execution via Workspace .env Override

    OpenClaw before 2026.5.27 contains an arbitrary code execution vulnerability in skill install flows where workspace .env files can override the Homebrew executable selection. Attackers with access to trusted operator workspaces can execute unintended Homebrew-compatible executables during skill setup to compromise the system.

    • Update to 2026.5.27
    Published Updated
  3. CVE-2026-53817

    High · CVSS 8.7EPSS 0.31%Fix available

    OpenClaw < 2026.5.22 - Control UI Locality Spoofing in Device Pairing

    OpenClaw before 2026.5.22 contains a locality validation vulnerability in Control UI pairing that allows attackers with network access to spoof locality information and obtain durable admin-capable device tokens. Attackers can exploit insufficient locality-derived trust validation to convert temporary shared access into persistent administrative credentials that survive token rotation.

    • Update to 2026.5.22
    Published Updated
  4. CVE-2026-53816

    High · CVSS 8.6EPSS 0.34%Fix available

    OpenClaw < 2026.5.18 - Exec Lifecycle Event Forgery via Paired Node

    OpenClaw before 2026.5.18 contains an insufficient provenance validation vulnerability in node event handling that allows paired nodes to forge exec lifecycle events without system.run authorization. A malicious or compromised paired node can send crafted node.event messages to the gateway, steering target sessions into exec-event paths that expose capabilities the reduced node surface should not provide.

    • Update to 2026.5.18
    Published Updated
  5. CVE-2026-53815

    High · CVSS 7.1EPSS 0.21%Fix available

    OpenClaw < 2026.5.19 - Channel Allowlist Bypass in Message Read Actions

    OpenClaw before 2026.5.19 contains an authorization bypass vulnerability in message read actions that skips channel allowlist checks. Lower-trust callers can request messages from channels not intended for them by exploiting insufficient validation in the affected feature, potentially exposing sensitive channel messages.

    • Update to 2026.5.19
    Published Updated
  6. CVE-2026-53814

    High · CVSS 8.7EPSS 0.28%Fix available

    OpenClaw < 2026.5.20 - Privilege Escalation via Hook-Triggered CLI MCP Tool Authority

    OpenClaw before 2026.5.20 contains a privilege escalation vulnerability where hook-triggered agent runs incorrectly receive owner-scoped MCP loopback authority instead of hook-appropriate scope. Attackers with a valid hook token can exploit the /hooks/agent endpoint to cause spawned CLI runtimes to access or invoke owner-only MCP tools, potentially executing privileged actions like persistent cron state modifications.

    • Update to 2026.5.20
    Published Updated
  7. CVE-2026-53812

    Medium · CVSS 4.9EPSS 0.25%Fix available

    OpenClaw < 2026.5.18 - Private-Network Navigation Bypass via Browser Act Interactions

    OpenClaw before 2026.5.18 contains a server-side request forgery vulnerability in browser control that allows authenticated users to bypass private-network navigation checks through Playwright act interactions. Attackers can trigger navigation to private-network targets via action-triggered redirects and subsequently read restricted page content using browser evaluation capabilities.

    • Update to 2026.5.18
    Published Updated
  8. CVE-2026-53810

    High · CVSS 7.7EPSS 0.42%Fix available

    OpenClaw < 2026.5.18 - Arbitrary Code Execution via Unscanned Marketplace Runtime Extension Metadata

    OpenClaw before 2026.5.18 contains a code execution vulnerability where marketplace runtime extension metadata can redirect loading toward unscanned package payloads. Attackers with trusted operator access can manipulate extension metadata to load plugin code outside reviewed package entry points, bypassing security scanning.

    • Update to 2026.5.18
    Published Updated
  9. CVE-2026-53806

    High · CVSS 7.7EPSS 0.42%Fix available

    OpenClaw < 2026.5.12 - Shell Option Parsing Bypass in Exec Revalidation

    OpenClaw before 2026.5.12 contains a shell option parsing vulnerability that allows combined POSIX shell flags to bypass exec revalidation checks. Attackers can exploit this by using combined shell options to execute inline shell content without intended allowlist validation, potentially enabling unauthorized command execution when the affected feature is enabled.

    • Update to 2026.5.12
    Published Updated
  10. CVE-2026-35674

    High · CVSS 8.7EPSS 0.25%Fix available

    OpenClaw < 2026.5.18 - Scope Bypass via Inherited chat.send Route

    OpenClaw before 2026.5.18 contains a scope bypass vulnerability in the Gateway chat.send route that allows scoped clients to execute privileged commands. Attackers with operator.write scope can deliver commands through inherited external routes to bypass operator.approvals and operator.admin scope requirements, enabling unauthorized plugin, config, MCP, allowlist, and ACP mutations.

    • Update to 2026.5.18
    Published Updated
  11. CVE-2026-35630

    High · CVSS 7.5EPSS 0.21%Fix available

    OpenClaw < 2026.5.18 - QQBot Missing Approver Identity Enforcement in Native Approval Buttons

    OpenClaw before 2026.5.18 contains an authorization bypass vulnerability in QQBot native approval buttons that fails to enforce configured approver identity. Non-approver users can click approval buttons to resolve pending exec or plugin approval requests without proper authorization.

    • Update to 2026.5.18
    Published Updated
  12. CVE-2026-32906

    Low · CVSS 2.3EPSS 0.17%Fix available

    OpenClaw < 2026.5.12 - Privilege Escalation in Slack Plugin Approvals via Exec Approver Gate

    OpenClaw before 2026.5.12 contains a privilege escalation vulnerability in Slack plugin approvals that allows exec-authorized users to resolve plugin approvals through the exec approver gate. Attackers with limited exec approval permissions can bypass intended approval splits to approve plugin actions outside operator configuration.

    • Update to 2026.5.12
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →