p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 187

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2023-40033

    High · CVSS 7.1EPSS 0.5%Fix available

    Server-Side Request Forgery via Avatar upload in flarum

    Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, discl

    • Update to 1.8.0
    Published Updated
  2. CVE-2023-3824

    Critical · CVSS 9.4EPSS 21.79%Fix available

    Buffer overflow and overread in phar_dir_read()

    In PHP version 8.0.* before 8.0.30,  8.1.* before 8.1.22, and 8.2.* before 8.2.8, when loading phar file, while reading PHAR directory entries, insufficient length checking may lead to a stack buffer overflow, leading potentially to memory corruption or RCE.

    • Update to 7.0.33-0ubuntu0.16.04.16+esm8
    • Update to 7.2.24-0ubuntu0.18.04.17+esm2
    • Update to 7.4.3-4ubuntu2.20
    • Update to 8.0.30
    • Update to 8.1.2-1ubuntu2.14
    • Update to 8.1.22
    • Update to 8.2.18-1~deb12u1
    • Update to 8.2.8
    Published Updated
  3. CVE-2023-3823

    High · CVSS 8.6EPSS 1.64%Fix available

    Security issue with external entity loading in XML without enabling it

    In PHP versions 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* before 8.2.8 various XML functions rely on libxml global state to track configuration variables, like whether external entities are loaded. This state is assumed to be unchanged unless the user explicitly changes it by calling appropriate function. However, since the state is process-global, other modules - such as ImageMagick - may also use this library within the same process, and change that global state for their internal purposes, and leave it in a state where external entities loading is enabled. This can lead to the situation where external XML is parsed with external

    • Update to 7.0.33-0ubuntu0.16.04.16+esm10
    • Update to 7.2.24-0ubuntu0.18.04.17+esm4
    • Update to 7.4.3-4ubuntu2.20
    • Update to 8.0.30
    • Update to 8.1.2-1ubuntu2.14
    • Update to 8.1.22
    • Update to 8.2.18-1~deb12u1
    • Update to 8.2.8
    Published Updated
  4. CVE-2023-38207

    High · CVSS 7.5EPSS 1.07%Fix available

    Adobe Commerce XML Injection (aka Blind XPath Injection) Arbitrary file system read

    Adobe Commerce versions 2.4.6-p1 (and earlier), 2.4.5-p3 (and earlier) and 2.4.4-p4 (and earlier) are affected by a XML Injection (aka Blind XPath Injection) vulnerability that could lead in minor arbitrary file system read. Exploitation of this issue does not require user interaction.

    • Update to 2.4.4-p5
    • Update to 2.4.5-p4
    • Update to 2.4.6-p2
    Published Updated
  5. CVE-2023-38208

    Critical · CVSS 9.1EPSS 2.55%Fix available

    Validate Your Inputs | Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') (CWE-78)

    Adobe Commerce versions 2.4.6-p1 (and earlier), 2.4.5-p3 (and earlier) and 2.4.4-p4 (and earlier) are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead to arbitrary code execution by an admin-privilege authenticated attacker. Exploitation of this issue does not require user interaction.

    • Update to 2.4.4-p5
    • Update to 2.4.5-p4
    • Update to 2.4.6-p2
    Published Updated
  6. CVE-2023-38209

    Medium · CVSS 6.5EPSS 0.97%Fix available

    Adobe Commerce Incorrect Authorization Security feature bypass

    Adobe Commerce versions 2.4.6-p1 (and earlier), 2.4.5-p3 (and earlier) and 2.4.4-p4 (and earlier) are affected by an Incorrect Authorization vulnerability that could lead to a Security feature bypass. A low-privileged attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.

    • Update to 2.4.4-p5
    • Update to 2.4.5-p4
    • Update to 2.4.6-p2
    Published Updated
  7. CVE-2023-39530

    Medium · CVSS 6.5EPSS 0.86%Fix available

    PrestaShop vulnerable to file deletion via CustomerMessage

    PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete files from the server via the CustomerMessage API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

    • Update to 8.1.1
    Published Updated
  8. CVE-2023-39529

    Medium · CVSS 6.7EPSS 0.71%Fix available

    PrestaShop vulnerable to file deletion via attachment API

    PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete a file from the server by using the Attachments controller and the Attachments API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

    • Update to 8.1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →