p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 188

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2023-39528

    Medium · CVSS 6.8EPSS 0.76%Fix available

    PrestaShop vulnerable to file reading through path traversal

    PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, the `displayAjaxEmailHTML` method can be used to read any file on the server, potentially even outside of the project if the server is not correctly configured. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

    • Update to 8.1.1
    Published Updated
  2. CVE-2023-39527

    High · CVSS 8.3EPSS 0.51%Fix available

    PrestaShop XSS vulnerability through Validate::isCleanHTML method

    PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to cross-site scripting through the `isCleanHTML` method. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.

    • Update to 1.7.8.10
    • Update to 8.0.5
    • Update to 8.1.1
    Published Updated
  3. CVE-2023-39526

    Critical · CVSS 9.1EPSS 1.69%Fix available

    PrestaShopSQL manager vulnerability (potential RCE)

    PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to remote code execution through SQL injection and arbitrary file write in the back office. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.

    • Update to 1.7.8.10
    • Update to 8.0.5
    • Update to 8.1.1
    Published Updated
  4. CVE-2023-39525

    Medium · CVSS 6.5EPSS 0.86%Fix available

    PrestaShop vulnerable to path traversal

    PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, in the back office, files can be compromised using path traversal by replaying the import file deletion query with a specified file path that uses the traversal path. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

    • Update to 8.1.1
    Published Updated
  5. CVE-2023-39524

    Medium · CVSS 6.7EPSS 0.66%Fix available

    PrestaShop vulnerable to boolean SQL injection in search product in BO

    PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, SQL injection possible in the product search field, in BO's product page. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

    • Update to 8.1.1
    Published Updated
  6. CVE-2023-38708

    Medium · CVSS 6.3EPSS 0.64%Fix available

    Pimcore Path Traversal Vulnerability in AssetController:importServerFilesAction

    Pimcore is an Open Source Data & Experience Management Platform: PIM, MDM, CDP, DAM, DXP/CMS & Digital Commerce. A path traversal vulnerability exists in the `AssetController::importServerFilesAction`, which allows an attacker to overwrite or modify sensitive files by manipulating the pimcore_log parameter.This can lead to potential denial of service---key file overwrite. The impact of this vulnerability allows attackers to: overwrite or modify sensitive files, potentially leading to unauthorized access, privilege escalation, or disclosure of confidential information. This could also cause a denial of service (DoS) if critical system files ar

    • Update to 10.6.7
    Published Updated
  7. CVE-2023-39343

    Medium · CVSS 4.3EPSS 0.62%Fix available

    Sulu Observable Response Discrepancy on Admin Login

    Sulu is an open-source PHP content management system based on the Symfony framework. It allows over the Admin Login form to detect which user (username, email) exists and which one do not exist. Sulu Installation not using the old Symfony 5.4 security System and previous version are not impacted by this Security issue. The vulnerability has been patched in version 2.5.10.

    • Update to 2.5.10
    Published Updated
  8. CVE-2023-29689

    Critical · CVSS 9.8EPSS 53.46%Public exploitNo fix published

    CVE-2023-29689

    PyroCMS 3.9 contains a remote code execution (RCE) vulnerability that can be exploited through a server-side template injection (SSTI) flaw. This vulnerability allows a malicious attacker to send customized commands to the server and execute arbitrary code on the affected system.

    Published Updated
  9. DRUPAL-CONTRIB-2023-033

    Not ratedFix available

    DRUPAL-CONTRIB-2023-033

    This module enables you to add the Matomo web statistics tracking system to your website. The module does not check the Matomo JS code loaded on the website. So a user could configure the module to load JS from a malicious website. This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer matomo" or "administer matomo tag manager" (D8+ only) to access the settings forms where this can be configured.

    • Update to 1.22.0
    Published Updated
  10. GHSA-4q66-g4mm-8rg5

    Medium · CVSS 5.4Fix available

    Silverstripe has Cross-site Scripting (XSS) vulnerabilities inherited from TinyMCE

    TinyMCE 4.x is vulnerable to several XSS vectors, which had been patched in later versions. Two of these have been identified as affecting `silverstripe/admin`. Only Silverstripe CMS 4 is affected by this issue. It's not possible to upgrade Silverstripe CMS 4 to use a more recent release of TinyMCE without introducing breaking changes. Instead, the security patches that shipped in later releases of TinyMCE have been backported to the TinyMCE version bundled in `silverstripe/admin`. Silverstripe CMS 5 is not affected by those vulnerabilities because it uses TinyMCE 6. You can find more information about the underlying vulnerabilities in tho

    • Update to 1.13.6
    Published Updated
  11. CVE-2023-32302

    Low · CVSS 0Fix available

    Silverstripe Framework: Members with no password can be created and bypass custom login forms

    When a new `Member` record was created in the cms it was possible to set a blank password. If an attacker knows the email address of the user with the blank password then they can attempt to log in using an empty password. The default member authenticator, login form and basic auth all require a non-empty password, however if a custom authentication method is used it may allow a successful login with the empty password. Starting with this release, blank passwords are no no longer allowed when members are created in the CMS. Programatically created `Member` records, such as those used in unit tests, still allow blank passwords. You may have so

    • Update to 4.13.14
    • Update to 5.0.13
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →