p PatchFirst

PatchFirst · Latest vulnerabilities

ruby1.9.1 vulnerabilities · Page 2

Vulnerabilities published for ruby1.9.1 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 37

  1. CVE-2017-17405

    High · CVSS 8.8EPSS 73.83%Public exploitFix available

    CVE-2017-17405

    Ruby before 2.4.3 allows Net::FTP command injection. Net::FTP#get, getbinaryfile, gettextfile, put, putbinaryfile, and puttextfile use Kernel#open to open a local file. If the localfile argument starts with the "|" pipe character, the command following the pipe character is executed. The default value of localfile is File.basename(remotefile), so malicious FTP servers could cause arbitrary command execution.

    • Update to 1.9.3.484-2ubuntu1.6
    Published Updated
  2. CVE-2017-0898

    Critical · CVSS 9.1EPSS 9.72%Fix available

    CVE-2017-0898

    Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

    • Update to 1.9.3.484-2ubuntu1.5
    Published Updated
  3. CVE-2017-14064

    Critical · CVSS 9.8EPSS 9.45%Fix available

    CVE-2017-14064

    Ruby through 2.2.7, 2.3.x through 2.3.4, and 2.4.x through 2.4.1 can expose arbitrary memory during a JSON.generate call. The issues lies in using strdup in ext/json/ext/generator/generator.c, which will stop after encountering a '\0' byte, returning a pointer to a string of length zero, which is not the length stored in space_len.

    • Update to 1.9.3.484-2ubuntu1.5
    Published Updated
  4. CVE-2016-2339

    Critical · CVSS 9.8EPSS 5.14%Fix available

    CVE-2016-2339

    An exploitable heap overflow vulnerability exists in the Fiddle::Function.new "initialize" function functionality of Ruby. In Fiddle::Function.new "initialize" heap buffer "arg_types" allocation is made based on args array length. Specially constructed object passed as element of args array can increase this array size after mentioned allocation and cause heap overflow.

    • Update to 1.9.3.484-2ubuntu1.3
    Published Updated
  5. CVE-2014-8090

    Not ratedEPSS 5.71%Fix available

    CVE-2014-8090

    The REXML parser in Ruby 1.9.x before 1.9.3 patchlevel 551, 2.0.x before 2.0.0 patchlevel 598, and 2.1.x before 2.1.5 allows remote attackers to cause a denial of service (CPU and memory consumption) a crafted XML document containing an empty string in an entity that is used in a large number of nested entity references, aka an XML Entity Expansion (XEE) attack. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-1821 and CVE-2014-8080.

    • Update to 1.9.3.484-2ubuntu1.2
    Published Updated
  6. CVE-2014-4975

    Not ratedEPSS 3.46%Fix available

    CVE-2014-4975

    Off-by-one error in the encodes function in pack.c in Ruby 1.9.3 and earlier, and 2.x through 2.1.2, when using certain format string specifiers, allows context-dependent attackers to cause a denial of service (segmentation fault) via vectors that trigger a stack-based buffer overflow.

    • Update to 1.9.3.484-2ubuntu1.1
    Published Updated
  7. CVE-2013-4164

    Not ratedEPSS 34.97%Public exploitFix available

    CVE-2013-4164

    Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse.

    • Update to 1.9.3.448-1ubuntu2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →