p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 2

Vulnerabilities published for ghostscript in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 94

  1. CVE-2020-16293

    Medium · CVSS 5.5EPSS 1.77%Fix available

    CVE-2020-16293

    A null pointer dereference vulnerability in compose_group_nonknockout_nonblend_isolated_allmask_common() in base/gxblend.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.13
    Published Updated
  2. CVE-2019-14812

    High · CVSS 7.3EPSS 2.47%Fix available

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.11
    Published Updated
  3. CVE-2019-10216

    High · CVSS 7.3EPSS 2.3%Fix available

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.10
    Published Updated
  4. CVE-2019-14869

    High · CVSS 7.3EPSS 3.09%Fix available

    CVE-2019-14869

    A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.12
    Published Updated
  5. CVE-2019-14813

    High · CVSS 7.3EPSS 10.96%Fix available

    CVE-2019-14813

    A flaw was found in ghostscript, versions 9.x before 9.50, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.11
    Published Updated
  6. CVE-2019-14817

    High · CVSS 7.3EPSS 2.02%Fix available

    CVE-2019-14817

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdfexectoken and other procedures where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.11
    Published Updated
  7. CVE-2019-14811

    High · CVSS 7.3EPSS 3.75%Fix available

    CVE-2019-14811

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdf_hook_DSC_Creator procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.11
    Published Updated
  8. CVE-2019-3839

    High · CVSS 7.3EPSS 1.71%Fix available

    CVE-2019-3839

    It was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.9
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →