p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 5

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 170

  1. CVE-2020-15900

    Critical · CVSS 9.8EPSS 5.19%Fix available

    CVE-2020-15900

    A memory corruption issue was found in Artifex Ghostscript 9.50 and 9.52. Use of a non-standard PostScript operator can allow overriding of file access controls. The 'rsearch' calculation for the 'post' size resulted in a size that was too large, and could underflow to max uint32_t. This was fixed in commit 5d499272b95a6b890a1397e11d20937de000d31b.

    • Update to 9.52.1~dfsg-1
    Published Updated
  2. CVE-2019-14812

    High · CVSS 7.3EPSS 2.47%Fix available

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated
  3. CVE-2019-10216

    High · CVSS 7.3EPSS 2.3%Fix available

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Update to 9.27~dfsg-3.1
    Published Updated
  4. CVE-2019-14869

    High · CVSS 7.3EPSS 3.09%Fix available

    CVE-2019-14869

    A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.

    • Update to 9.50~dfsg-3
    Published Updated
  5. CVE-2019-14813

    High · CVSS 7.3EPSS 10.96%Fix available

    CVE-2019-14813

    A flaw was found in ghostscript, versions 9.x before 9.50, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated
  6. CVE-2019-14817

    High · CVSS 7.3EPSS 2.02%Fix available

    CVE-2019-14817

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdfexectoken and other procedures where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated
  7. CVE-2019-14811

    High · CVSS 7.3EPSS 3.75%Fix available

    CVE-2019-14811

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdf_hook_DSC_Creator procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.28~~rc2~dfsg-1
    Published Updated
  8. CVE-2017-15652

    Medium · CVSS 5.5EPSS 1.3%Fix available

    CVE-2017-15652

    Artifex Ghostscript 9.22 is affected by: Obtain Information. The impact is: obtain sensitive information. The component is: affected source code file, affected function, affected executable, affected libga (imagemagick used that). The attack vector is: Someone must open a postscript file though ghostscript. Because of imagemagick also use libga, so it was affected as well.

    • Update to 9.25~dfsg-1
    Published Updated
  9. CVE-2019-3839

    High · CVSS 7.3EPSS 1.76%Fix available

    CVE-2019-3839

    It was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable.

    • Update to 9.27~dfsg-1
    Published Updated
  10. CVE-2018-19134

    High · CVSS 7.8EPSS 2.87%Fix available

    CVE-2018-19134

    In Artifex Ghostscript through 9.25, the setpattern operator did not properly validate certain types. A specially crafted PostScript document could exploit this to crash Ghostscript or, possibly, execute arbitrary code in the context of the Ghostscript process. This is a type confusion issue because of failure to check whether the Implementation of a pattern dictionary was a structure type.

    • Update to 9.26~dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →