p PatchFirst

PatchFirst · Latest vulnerabilities

ansible vulnerabilities · Page 4

Vulnerabilities published for ansible in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 77

  1. CVE-2018-16837

    High · CVSS 7.8EPSS 0.36%Fix available

    CVE-2018-16837

    Ansible "User" module leaks any data which is passed on as a parameter to ssh-keygen. This could lean in undesirable situations such as passphrases credentials passed as a parameter for the ssh-keygen executable. Showing those credentials in clear text form for every user which have access just to the process list.

    • Update to 2.7.1+dfsg-1
    Published Updated
  2. CVE-2017-7481

    Medium · CVSS 5.3EPSS 4.78%Fix available

    CVE-2017-7481

    Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.

    • Update to 2.3.1.0+dfsg-1
    Published Updated
  3. CVE-2018-10855

    Medium · CVSS 5.9EPSS 3.11%Fix available

    CVE-2018-10855

    Ansible 2.5 prior to 2.5.5, and 2.4 prior to 2.4.5, do not honor the no_log task flag for failed tasks. When the no_log flag has been used to protect sensitive data passed to a task from being logged, and that task does not run successfully, Ansible will expose sensitive data in log files and on the terminal of the user running Ansible.

    • Update to 2.5.5+dfsg-1
    Published Updated
  4. CVE-2017-7466

    High · CVSS 8EPSS 3.14%Fix available

    CVE-2017-7466

    Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

    • Update to 2.2.1.0-2
    Published Updated
  5. CVE-2016-9587

    Medium · CVSS 6.6EPSS 17.14%Public exploitFix available

    CVE-2016-9587

    Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

    • Update to 2.2.0.0-3
    Published Updated
  6. CVE-2017-7550

    Critical · CVSS 9.8EPSS 3.56%Fix available

    CVE-2017-7550

    A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

    • Update to 2.4.2.0+dfsg-1
    Published Updated
  7. CVE-2016-3096

    High · CVSS 8.5EPSS 0.47%Fix available

    CVE-2016-3096

    The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on (1) /opt/.lxc-attach-script, (2) the archived container in the archive_path directory, or the (3) lxc-attach-script.log or (4) lxc-attach-script.err files in the temporary directory.

    • Update to 2.0.1.0-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →