p PatchFirst

PatchFirst · Latest vulnerabilities

mantisbt/mantisbt vulnerabilities · Page 4

Vulnerabilities published for mantisbt/mantisbt in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 74

  1. CVE-2018-14504

    Medium · CVSS 6.1EPSS 1.63%Fix available

    CVE-2018-14504

    An issue was discovered in manage_filter_edit_page.php in MantisBT 2.x through 2.15.0. A cross-site scripting (XSS) vulnerability in the Edit Filter page allows execution of arbitrary code (if CSP settings permit it) when displaying a filter with a crafted name (e.g., 'foobar" onclick="alert(1)').

    • Update to 2.15.1
    Published Updated
  2. CVE-2017-12061

    Medium · CVSS 6.1EPSS 2.94%Fix available

    CVE-2017-12061

    An XSS issue was discovered in admin/install.php in MantisBT before 1.3.12 and 2.x before 2.5.2. Some variables under user control in the MantisBT installation script are not properly sanitized before being output, allowing remote attackers to inject arbitrary JavaScript code, as demonstrated by the $f_database, $f_db_username, and $f_admin_username variables. This is mitigated by the fact that the admin/ folder should be deleted after installation, and also prevented by CSP.

    • Update to 1.3.12
    • Update to 2.5.2
    Published Updated
  3. CVE-2017-7620

    Medium · CVSS 6.5EPSS 1.36%Public exploitFix available

    CVE-2017-7620

    MantisBT before 1.3.11, 2.x before 2.3.3, and 2.4.x before 2.4.1 omits a backslash check in string_api.php and consequently has conflicting interpretations of an initial \/ substring as introducing either a local pathname or a remote hostname, which leads to (1) arbitrary Permalink Injection via CSRF attacks on a permalink_page.php?url= URI and (2) an open redirect via a login_page.php?return= URI.

    • Update to 1.3.11
    • Update to 2.3.3
    • Update to 2.4.1
    Published Updated
  4. CVE-2017-7897

    Medium · CVSS 6.1EPSS 1.75%Fix available

    CVE-2017-7897

    A cross-site scripting (XSS) vulnerability in the MantisBT (2.3.x before 2.3.2) Timeline include page, used in My View (my_view_page.php) and User Information (view_user_page.php) pages, allows remote attackers to inject arbitrary code (if CSP settings permit it) through crafted PATH_INFO in a URL, due to use of unsanitized $_SERVER['PHP_SELF'] to generate URLs.

    • Update to 2.3.2
    Published Updated
  5. CVE-2017-7309

    Medium · CVSS 4.8EPSS 57.32%Fix available

    CVE-2017-7309

    A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

    • Update to 1.3.9
    • Update to 2.1.3
    • Update to 2.2.3
    Published Updated
  6. CVE-2017-7241

    Medium · CVSS 4.8EPSS 0.93%Fix available

    CVE-2017-7241

    A cross-site scripting (XSS) vulnerability in the MantisBT Move Attachments page (move_attachments_page.php, part of admin tools) allows remote attackers to inject arbitrary code through a crafted 'type' parameter, if Content Security Protection (CSP) settings allows it. This is fixed in 1.3.9, 2.1.3, and 2.2.3. Note that this vulnerability is not exploitable if the admin tools directory is removed, as recommended in the "Post-installation and upgrade tasks" of the MantisBT Admin Guide. A reminder to do so is also displayed on the login page.

    • Update to 1.3.9
    • Update to 2.1.3
    • Update to 2.2.3
    Published Updated
  7. CVE-2017-6973

    Medium · CVSS 4.8EPSS 0.93%Fix available

    CVE-2017-6973

    A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code through a crafted 'action' parameter. This is fixed in 1.3.8, 2.1.2, and 2.2.2.

    • Update to 1.3.8
    • Update to 2.1.2
    • Update to 2.2.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →