p PatchFirst

PatchFirst · Latest vulnerabilities

moodle/moodle vulnerabilities · Page 8

Vulnerabilities published for moodle/moodle in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 437

  1. CVE-2023-23921

    Medium · CVSS 6.1EPSS 0.81%Fix available

    Moodle: reflected xss risk in some returnurl parameters

    The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in some returnurl parameters. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.

    • Update to 3.11.12
    • Update to 3.9.19
    • Update to 4.0.6
    • Update to 4.1.1
    Published Updated
  2. CVE-2022-45152

    Critical · CVSS 9.1EPSS 1.44%Fix available

    CVE-2022-45152

    A blind Server-Side Request Forgery (SSRF) vulnerability was found in Moodle. This flaw exists due to insufficient validation of user-supplied input in LTI provider library. The library does not utilise Moodle's inbuilt cURL helper, which resulted in a blind SSRF risk. An attacker can send a specially crafted HTTP request and trick the application to initiate requests to arbitrary systems. This vulnerability allows a remote attacker to perform SSRF attacks.

    • Update to 3.11.11
    • Update to 3.9.18
    • Update to 4.0.5
    Published Updated
  3. CVE-2022-45151

    Medium · CVSS 5.4EPSS 0.71%Fix available

    CVE-2022-45151

    The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

    • Update to 3.11.11
    • Update to 4.0.5
    Published Updated
  4. CVE-2022-45150

    Medium · CVSS 6.1EPSS 0.74%Fix available

    CVE-2022-45150

    A reflected cross-site scripting vulnerability was discovered in Moodle. This flaw exists due to insufficient sanitization of user-supplied data in policy tool. An attacker can trick the victim to open a specially crafted link that executes an arbitrary HTML and script code in user's browser in context of vulnerable website. This vulnerability may allow an attacker to perform cross-site scripting (XSS) attacks to gain access potentially sensitive information and modification of web pages.

    • Update to 3.11.11
    • Update to 3.9.18
    • Update to 4.0.5
    Published Updated
  5. CVE-2022-45149

    Medium · CVSS 5.4EPSS 0.44%Fix available

    CVE-2022-45149

    A vulnerability was found in Moodle which exists due to insufficient validation of the HTTP request origin in course redirect URL. A user's CSRF token was unnecessarily included in the URL when being redirected to a course they have just restored. A remote attacker can trick the victim to visit a specially crafted web page and perform arbitrary actions on behalf of the victim on the vulnerable website. This flaw allows an attacker to perform cross-site request forgery attacks.

    • Update to 3.11.11
    • Update to 3.9.18
    • Update to 4.0.5
    Published Updated
  6. CVE-2021-36568

    Medium · CVSS 5.4EPSS 1.04%Fix available

    CVE-2021-36568

    In certain Moodle products after creating a course, it is possible to add in a arbitrary "Topic" a resource, in this case a "Database" with the type "Text" where its values "Field name" and "Field description" are vulnerable to Cross Site Scripting Stored(XSS). This affects Moodle 3.11 and Moodle 3.10.4 and Moodle 3.9.7.

    • Update to 3.11.10
    Published Updated
  7. CVE-2022-35653

    Medium · CVSS 6.1EPSS 4.84%Public exploitFix available

    CVE-2022-35653

    A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

    • Update to 3.11.8
    • Update to 3.9.15
    • Update to 4.0.2
    Published Updated
  8. CVE-2022-35652

    Medium · CVSS 6.1EPSS 1.09%Fix available

    CVE-2022-35652

    An open redirect issue was found in Moodle due to improper sanitization of user-supplied data in mobile auto-login feature. A remote attacker can create a link that leads to a trusted website, however, when clicked, it redirects the victims to arbitrary URL/domain. Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.

    • Update to 3.11.8
    • Update to 3.9.15
    • Update to 4.0.2
    Published Updated
  9. CVE-2022-35651

    Medium · CVSS 6.1EPSS 1.08%Fix available

    CVE-2022-35651

    A stored XSS and blind SSRF vulnerability was found in Moodle, occurs due to insufficient sanitization of user-supplied data in the SCORM track details. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks.

    • Update to 3.11.8
    • Update to 3.9.15
    • Update to 4.0.2
    Published Updated
  10. CVE-2022-35650

    High · CVSS 7.5EPSS 53.65%Fix available

    CVE-2022-35650

    The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.

    • Update to 3.11.8
    • Update to 3.9.15
    • Update to 4.0.2
    Published Updated
  11. CVE-2022-35649

    Critical · CVSS 9.8EPSS 8.55%Fix available

    CVE-2022-35649

    The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

    • Update to 3.11.8
    • Update to 3.9.15
    • Update to 4.0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →