p PatchFirst

PatchFirst · Latest vulnerabilities

xen vulnerabilities · Page 5

Vulnerabilities published for xen in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 126

  1. CVE-2015-4106

    Not ratedEPSS 0.48%Fix available

    CVE-2015-4106

    QEMU does not properly restrict write access to the PCI config space for certain PCI pass-through devices, which might allow local x86 HVM guests to gain privileges, cause a denial of service (host crash), obtain sensitive information, or possibly have other unspecified impact via unknown vectors.

    • Update to 4.4.2-0ubuntu0.14.04.2
    Published Updated
  2. CVE-2015-4103

    Not ratedEPSS 0.45%Fix available

    CVE-2015-4103

    Xen 3.3.x through 4.5.x does not properly restrict write access to the host MSI message data field, which allows local x86 HVM guest administrators to cause a denial of service (host interrupt handling confusion) via vectors related to qemu and accessing spanning multiple fields.

    • Update to 4.4.2-0ubuntu0.14.04.2
    Published Updated
  3. CVE-2015-3456

    Not ratedEPSS 15.28%Public exploitFix available

    CVE-2015-3456

    The Floppy Disk Controller (FDC) in QEMU, as used in Xen 4.5.x and earlier and KVM, allows local guest users to cause a denial of service (out-of-bounds write and guest crash) or possibly execute arbitrary code via the (1) FD_CMD_READ_ID, (2) FD_CMD_DRIVE_SPECIFICATION_COMMAND, or other unspecified commands, aka VENOM.

    • Update to 4.4.1-0ubuntu0.14.04.6
    Published Updated
  4. CVE-2015-2756

    Not ratedEPSS 0.45%Fix available

    CVE-2015-2756

    QEMU, as used in Xen 3.3.x through 4.5.x, does not properly restrict access to PCI command registers, which might allow local HVM guest users to cause a denial of service (non-maskable interrupt and host crash) by disabling the (1) memory or (2) I/O decoding for a PCI Express device and then accessing the device, which triggers an Unsupported Request (UR) response.

    • Update to 4.4.1-0ubuntu0.14.04.5
    Published Updated
  5. CVE-2015-2752

    Not ratedEPSS 0.45%Fix available

    CVE-2015-2752

    The XEN_DOMCTL_memory_mapping hypercall in Xen 3.2.x through 4.5.x, when using a PCI passthrough device, is not preemptible, which allows local x86 HVM domain users to cause a denial of service (host CPU consumption) via a crafted request to the device model (qemu-dm).

    • Update to 4.4.1-0ubuntu0.14.04.5
    Published Updated
  6. CVE-2015-2152

    Not ratedEPSS 0.42%Fix available

    CVE-2015-2152

    Xen 4.5.x and earlier enables certain default backends when emulating a VGA device for an x86 HVM guest qemu even when the configuration disables them, which allows local guest users to obtain access to the VGA console by (1) setting the DISPLAY environment variable, when compiled with SDL support, or connecting to the VNC server on (2) ::1 or (3) 127.0.0.1, when not compiled with SDL support.

    • Update to 4.4.1-0ubuntu0.14.04.4
    Published Updated
  7. CVE-2015-2151

    Not ratedEPSS 0.55%Fix available

    CVE-2015-2151

    The x86 emulator in Xen 3.2.x through 4.5.x does not properly ignore segment overrides for instructions with register operands, which allows local guest users to obtain sensitive information, cause a denial of service (memory corruption), or possibly execute arbitrary code via unspecified vectors.

    • Update to 4.4.1-0ubuntu0.14.04.4
    Published Updated
  8. CVE-2014-9066

    Not ratedEPSS 0.4%Fix available

    CVE-2014-9066

    Xen 4.4.x and earlier, when using a large number of VCPUs, does not properly handle read and write locks, which allows local x86 guest users to cause a denial of service (write denial or NMI watchdog timeout and host crash) via a large number of read requests, a different vulnerability than CVE-2014-9065.

    • Update to 4.4.1-0ubuntu0.14.04.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →