p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 4

Vulnerabilities published for ghostscript in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 94

  1. CVE-2018-16509

    High · CVSS 7.8EPSS 92.5%Public exploitFix available

    CVE-2018-16509

    An issue was discovered in Artifex Ghostscript before 9.24. Incorrect "restoration of privilege" checking during handling of /invalidaccess exceptions could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction.

    • Update to 9.18~dfsg~0-0ubuntu2.9
    Published Updated
  2. CVE-2018-10194

    High · CVSS 7.8EPSS 2.05%Fix available

    CVE-2018-10194

    The set_text_distance function in devices/vector/gdevpdts.c in the pdfwrite component in Artifex Ghostscript through 9.22 does not prevent overflows in text-positioning calculation, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document.

    • Update to 9.18~dfsg~0-0ubuntu2.8
    Published Updated
  3. CVE-2018-5727

    Medium · CVSS 6.5EPSS 1.82%Fix available

    CVE-2018-5727

    In OpenJPEG 2.3.0, there is an integer overflow vulnerability in the opj_t1_encode_cblks function (openjp2/t1.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted bmp file.

    • Update to 9.26~dfsg+0-0ubuntu0.16.04.14
    Published Updated
  4. CVE-2017-11714

    High · CVSS 7.8EPSS 2.3%Fix available

    CVE-2017-11714

    psi/ztoken.c in Artifex Ghostscript 9.21 mishandles references to the scanner state structure, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PostScript document, related to an out-of-bounds read in the igc_reloc_struct_ptr function in psi/igc.c.

    • Update to 9.18~dfsg~0-0ubuntu2.7
    Published Updated
  5. CVE-2017-9835

    High · CVSS 7.8EPSS 2.79%Fix available

    CVE-2017-9835

    The gs_alloc_ref_array function in psi/ialloc.c in Artifex Ghostscript 9.21 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted PostScript document. This is related to a lack of an integer overflow check in base/gsalloc.c.

    • Update to 9.18~dfsg~0-0ubuntu2.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →