p PatchFirst

PatchFirst · Latest vulnerabilities

spip vulnerabilities

Vulnerabilities published for spip in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2021-44123

    High · CVSS 8.8EPSS 2.4%Fix available

    CVE-2021-44123

    SPIP 4.0.0 is affected by a remote command execution vulnerability. To exploit the vulnerability, an attacker must craft a malicious picture with a double extension, upload it and then click on it to execute it.

    • Update to 3.1.4-4~deb9u5build0.18.04.1
    Published Updated
  2. CVE-2021-44122

    High · CVSS 8.8EPSS 0.49%Fix available

    CVE-2021-44122

    SPIP 4.0.0 is affected by a Cross Site Request Forgery (CSRF) vulnerability in ecrire/public/aiguiller.php, ecrire/public/balises.php, ecrire/balise/formulaire_.php. To exploit the vulnerability, a visitor must visit a malicious website which redirects to the SPIP website. It is also possible to combine XSS vulnerabilities in SPIP 4.0.0 to exploit it. The vulnerability allows an authenticated attacker to execute malicious code without the knowledge of the user on the website (CSRF).

    • Update to 3.1.4-4~deb9u5build0.18.04.1
    Published Updated
  3. CVE-2021-44120

    Medium · CVSS 5.4EPSS 0.67%Fix available

    CVE-2021-44120

    SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability in ecrire/public/interfaces.php, adding the function safehtml to the vulnerable fields. An editor is able to modify his personal information. If the editor has an article written and available, when a user goes to the public site and wants to read the author's information, the malicious code will be executed. The "Who are you" and "Website Name" fields are vulnerable.

    • Update to 3.1.4-4~deb9u5build0.18.04.1
    Published Updated
  4. CVE-2021-44118

    Medium · CVSS 5.4EPSS 0.77%Fix available

    CVE-2021-44118

    SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

    • Update to 3.1.4-4~deb9u5build0.18.04.1
    Published Updated
  5. CVE-2017-15736

    Medium · CVSS 6.1EPSS 0.99%Fix available

    CVE-2017-15736

    Cross-site scripting (XSS) vulnerability (stored) in SPIP before 3.1.7 allows remote attackers to inject arbitrary web script or HTML via a crafted string, as demonstrated by a PGP field, related to prive/objets/contenu/auteur.html and ecrire/inc/texte_mini.php.

    • Update to 3.1.4-4~deb9u3build0.18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →