p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities · Page 2

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 77

  1. ALPINE-CVE-2022-22721

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2022-22721

    If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

    • Update to 2.4.53-r0
    Published Updated
  2. ALPINE-CVE-2021-44790

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-44790

    A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

    • Update to 2.4.52-r0
    Published Updated
  3. ALPINE-CVE-2021-44224

    High · CVSS 8.2Fix available

    ALPINE-CVE-2021-44224

    A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).

    • Update to 2.4.52-r0
    Published Updated
  4. ALPINE-CVE-2021-42013

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-42013

    It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.

    • Update to 2.4.51-r0
    Published Updated
  5. ALPINE-CVE-2021-41773

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-41773

    A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42

    • Update to 2.4.50-r0
    Published Updated
  6. ALPINE-CVE-2021-41524

    High · CVSS 7.5Fix available

    ALPINE-CVE-2021-41524

    While fuzzing the 2.4.49 httpd, a new null pointer dereference was detected during HTTP/2 request processing, allowing an external source to DoS the server. This requires a specially crafted request. The vulnerability was recently introduced in version 2.4.49. No exploit is known to the project.

    • Update to 2.4.50-r0
    Published Updated
  7. ALPINE-CVE-2021-39275

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-39275

    ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.

    • Update to 2.4.49-r0
    Published Updated
  8. ALPINE-CVE-2021-31618

    High · CVSS 7.5Fix available

    ALPINE-CVE-2021-31618

    Apache HTTP Server protocol handler for the HTTP/2 protocol checks received request headers against the size limitations as configured for the server and used for the HTTP/1 protocol as well. On violation of these restrictions and HTTP response is sent to the client with a status code indicating why the request was rejected. This rejection response was not fully initialised in the HTTP/2 protocol handler if the offending header was the very first one received or appeared in a a footer. This led to a NULL pointer dereference on initialised memory, crashing reliably the child process. Since such a triggering HTTP/2 request is easy to craft and

    • Update to 2.4.48-r0
    Published Updated
  9. ALPINE-CVE-2020-35452

    High · CVSS 7.3Fix available

    ALPINE-CVE-2020-35452

    Apache HTTP Server versions 2.4.0 to 2.4.46 A specially crafted Digest nonce can cause a stack overflow in mod_auth_digest. There is no report of this overflow being exploitable, nor the Apache HTTP Server team could create one, though some particular compiler and/or compilation option might make it possible, with limited consequences anyway due to the size (a single byte) and the value (zero byte) of the overflow

    • Update to 2.4.48-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →