p PatchFirst

PatchFirst · Latest vulnerabilities

ansible vulnerabilities · Page 3

Vulnerabilities published for ansible in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 74

  1. CVE-2020-1734

    High · CVSS 7.4EPSS 0.46%No fix published

    CVE-2020-1734

    A flaw was found in the pipe lookup plugin of ansible. Arbitrary commands can be run, when the pipe lookup plugin uses subprocess.Popen() with shell=True, by overwriting ansible facts and the variable is not escaped by quote plugin. An attacker could take advantage and run arbitrary commands by overwriting the ansible facts.

    Published Updated
  2. CVE-2014-4660

    Medium · CVSS 6.8EPSS 0.38%Fix available

    CVE-2014-4660

    Ansible before 1.5.5 constructs filenames containing user and password fields on the basis of deb lines in sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by leveraging existence of a file that uses the "deb http://user:pass@server:port/" format.

    • Update to 1.5.5+dfsg-1
    Published Updated
  3. CVE-2014-4967

    Critical · CVSS 9.8EPSS 3.55%Fix available

    CVE-2014-4967

    Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact with (1) a trailing " src=" clause, (2) a trailing " temp=" clause, or (3) a trailing " validate=" clause accompanied by a shell command.

    • Update to 1.6.8+dfsg-1
    Published Updated
  4. CVE-2019-14864

    Medium · CVSS 5.7EPSS 1.87%Fix available

    CVE-2019-14864

    Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used send tasks results events to collectors. This would discloses and collects any sensitive data.

    • Update to 2.9.2+dfsg-1
    Published Updated
  5. CVE-2019-10217

    Medium · CVSS 5.7EPSS 1.87%Fix available

    CVE-2019-10217

    A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

    • Update to 2.8.6+dfsg-1
    Published Updated
  6. CVE-2019-10206

    Medium · CVSS 6.4EPSS 1.52%Fix available

    CVE-2019-10206

    ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

    • Update to 2.8.6+dfsg-1
    Published Updated
  7. CVE-2019-14858

    High · CVSS 7.3EPSS 0.42%Fix available

    CVE-2019-14858

    A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.

    • Update to 2.8.6+dfsg-1
    Published Updated
  8. CVE-2019-14846

    High · CVSS 7.3EPSS 0.51%Fix available

    CVE-2019-14846

    In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

    • Update to 2.8.6+dfsg-1
    Published Updated
  9. CVE-2019-10156

    Medium · CVSS 4.6EPSS 1.77%Fix available

    CVE-2019-10156

    A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

    • Update to 2.8.3+dfsg-1
    Published Updated
  10. CVE-2018-16837

    High · CVSS 7.8EPSS 0.36%Fix available

    CVE-2018-16837

    Ansible "User" module leaks any data which is passed on as a parameter to ssh-keygen. This could lean in undesirable situations such as passphrases credentials passed as a parameter for the ssh-keygen executable. Showing those credentials in clear text form for every user which have access just to the process list.

    • Update to 2.7.1+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →