p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 10

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 283

  1. CVE-2015-8628

    Medium · CVSS 5.3EPSS 1.41%Fix available

    CVE-2015-8628

    The (1) Special:MyPage, (2) Special:MyTalk, (3) Special:MyContributions, (4) Special:MyUploads, and (5) Special:AllMyUploads pages in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1 allow remote attackers to obtain sensitive user login information via crafted links combined with page view statistics.

    • Update to 1:1.25.5-1
    Published Updated
  2. CVE-2015-8627

    Medium · CVSS 5.3EPSS 1.36%Fix available

    CVE-2015-8627

    MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1 do not properly normalize IP addresses containing zero-padded octets, which might allow remote attackers to bypass intended access restrictions by using an IP address that was not supposed to have been allowed.

    • Update to 1:1.25.5-1
    Published Updated
  3. CVE-2015-8624

    High · CVSS 8.8EPSS 0.75%Fix available

    CVE-2015-8624

    The User::matchEditToken function in includes/User.php in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1 does not perform token comparison in constant time before determining if a debugging message should be logged, which allows remote attackers to guess the edit token and bypass CSRF protection via a timing attack, a different vulnerability than CVE-2015-8623.

    • Update to 1:1.25.5-1
    Published Updated
  4. CVE-2015-8623

    High · CVSS 8.8EPSS 0.73%Fix available

    CVE-2015-8623

    The User::matchEditToken function in includes/User.php in MediaWiki before 1.23.12 and 1.24.x before 1.24.5 does not perform token comparison in constant time before returning, which allows remote attackers to guess the edit token and bypass CSRF protection via a timing attack, a different vulnerability than CVE-2015-8624.

    • Update to 1:1.25.5-1
    Published Updated
  5. CVE-2015-8622

    Medium · CVSS 6.1EPSS 1.48%Fix available

    CVE-2015-8622

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1, when is configured with a relative URL, allows remote authenticated users to inject arbitrary web script or HTML via wikitext, as demonstrated by a wikilink to a page named "javascript:alert('XSS!')."

    • Update to 1:1.25.5-1
    Published Updated
  6. CVE-2015-8004

    Not ratedEPSS 1.72%Fix available

    CVE-2015-8004

    MediaWiki before 1.23.11, 1.24.x before 1.24.4, and 1.25.x before 1.25.3 does not properly restrict access to revisions, which allows remote authenticated users with the viewsuppressed user right to remove revision suppressions via a crafted revisiondelete action, which returns a valid a change form.

    • Update to 1:1.25.5-1
    Published Updated
  7. CVE-2015-6730

    Not ratedEPSS 2.01%Fix available

    CVE-2015-6730

    Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.23.10, 1.24.x before 1.24.3, and 1.25.x before 1.25.2 allows remote attackers to inject arbitrary web script or HTML via the f parameter, which is not properly handled in an error page, related to "ForeignAPI images."

    • Update to 1:1.25.5-1
    Published Updated
  8. CVE-2015-2942

    Not ratedEPSS 2.81%Fix available

    CVE-2015-2942

    MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM, allows remote attackers to cause a denial of service (CPU and memory consumption) via a large number of nested entity references in an (1) SVG file or (2) XMP metadata in a PDF file, aka a "billion laughs attack," a different vulnerability than CVE-2015-2937.

    • Update to 1:1.19.20+dfsg-2.3
    Published Updated
  9. CVE-2015-2941

    Not ratedEPSS 2.1%Fix available

    CVE-2015-2941

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM, allows remote attackers to inject arbitrary web script or HTML via an invalid parameter in a wddx format request to api.php, which is not properly handled in an error message, related to unsafe calls to wddx_serialize_value.

    • Update to 1:1.19.20+dfsg-2.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →