p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 11

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 283

  1. CVE-2015-2937

    Not ratedEPSS 2.69%Fix available

    CVE-2015-2937

    MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM or Zend PHP, allows remote attackers to cause a denial of service ("quadratic blowup" and memory consumption) via an XML file containing an entity declaration with long replacement text and many references to this entity, a different vulnerability than CVE-2015-2942.

    • Update to 1:1.19.20+dfsg-2.3
    Published Updated
  2. CVE-2014-9277

    Not ratedEPSS 1.97%Fix available

    CVE-2014-9277

    The wfMangleFlashPolicy function in OutputHandler.php in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7 allows remote attackers to conduct PHP object injection attacks via a crafted string containing <cross-domain-policy> in a PHP format request, which causes the string length to change when converting the request to <NOT-cross-domain-policy>.

    • Update to 1:1.19.20+dfsg-2.1
    Published Updated
  3. CVE-2014-7295

    Not ratedEPSS 1.57%Fix available

    CVE-2014-7295

    The (1) Special:Preferences and (2) Special:UserLogin pages in MediaWiki before 1.19.20, 1.22.x before 1.22.12 and 1.23.x before 1.23.5 allows remote authenticated users to conduct cross-site scripting (XSS) attacks or have unspecified other impact via crafted CSS, as demonstrated by modifying MediaWiki:Common.css.

    • Update to 1:1.19.20+dfsg-1
    Published Updated
  4. CVE-2014-5241

    Not ratedEPSS 0.84%Fix available

    CVE-2014-5241

    The JSONP endpoint in includes/api/ApiFormatJson.php in MediaWiki before 1.19.18, 1.20.x through 1.22.x before 1.22.9, and 1.23.x before 1.23.2 accepts certain long callback values and does not restrict the initial bytes of a JSONP response, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks, and obtain sensitive information, via a crafted OBJECT element with SWF content consistent with a restricted character set.

    • Update to 1:1.19.18+dfsg-0.1
    Published Updated
  5. CVE-2013-6472

    Not ratedEPSS 1.27%Fix available

    CVE-2013-6472

    MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to obtain information about deleted page via the (1) log API, (2) enhanced RecentChanges, and (3) user watchlists.

    • Update to 1:1.19.10+dfsg-1
    Published Updated
  6. CVE-2013-6452

    Not ratedEPSS 1.01%Fix available

    CVE-2013-6452

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via crafted XSL in an SVG file.

    • Update to 1:1.19.10+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →