p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 12

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 283

  1. CVE-2014-2665

    Not ratedEPSS 1.06%Fix available

    CVE-2014-2665

    includes/specials/SpecialChangePassword.php in MediaWiki before 1.19.14, 1.20.x and 1.21.x before 1.21.8, and 1.22.x before 1.22.5 does not properly handle a correctly authenticated but unintended login attempt, which makes it easier for remote authenticated users to obtain sensitive information by arranging for a victim to login to the attacker's account, as demonstrated by tracking the victim's activity, related to a "login CSRF" issue.

    • Update to 1:1.19.14+dfsg-1
    Published Updated
  2. CVE-2014-2243

    Not ratedEPSS 1.55%Fix available

    CVE-2014-2243

    includes/User.php in MediaWiki before 1.19.12, 1.20.x and 1.21.x before 1.21.6, and 1.22.x before 1.22.3 terminates validation of a user token upon encountering the first incorrect character, which makes it easier for remote attackers to obtain access via a brute-force attack that relies on timing differences in responses to incorrect token guesses.

    • Update to 1:1.19.12+dfsg-1
    Published Updated
  3. CVE-2014-2242

    Not ratedEPSS 2.44%Fix available

    CVE-2014-2242

    includes/upload/UploadBase.php in MediaWiki before 1.19.12, 1.20.x and 1.21.x before 1.21.6, and 1.22.x before 1.22.3 does not prevent use of invalid namespaces in SVG files, which allows remote attackers to conduct cross-site scripting (XSS) attacks via an SVG upload, as demonstrated by use of a W3C XHTML namespace in conjunction with an IFRAME element.

    • Update to 1:1.19.12+dfsg-1
    Published Updated
  4. CVE-2014-1610

    Not ratedEPSS 42.78%Public exploitFix available

    CVE-2014-1610

    MediaWiki 1.22.x before 1.22.2, 1.21.x before 1.21.5, and 1.19.x before 1.19.11, when DjVu or PDF file upload support is enabled, allows remote attackers to execute arbitrary commands via shell metacharacters in (1) the page parameter to includes/media/DjVu.php; (2) the w parameter (aka width field) to thumb.php, which is not properly handled by includes/media/PdfHandler_body.php; and possibly unspecified vectors in (3) includes/media/Bitmap.php and (4) includes/media/ImageHandler.php.

    • Update to 1:1.19.11+dfsg-1
    Published Updated
  5. CVE-2013-4568

    Not ratedEPSS 2.1%Fix available

    CVE-2013-4568

    Incomplete blacklist vulnerability in Sanitizer::checkCss in MediaWiki before 1.19.9, 1.20.x before 1.20.8, and 1.21.x before 1.21.3 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain non-ASCII characters in CSS, as demonstrated using variations of "expression" containing (1) full width characters or (2) IPA extensions, which are converted and rendered by Internet Explorer.

    • Update to 1:1.19.8+dfsg-2.2
    Published Updated
  6. CVE-2013-2032

    Not ratedEPSS 2.51%Fix available

    CVE-2013-2032

    MediaWiki before 1.19.6 and 1.20.x before 1.20.5 does not allow extensions to prevent password changes without using both Special:PasswordReset and Special:ChangePassword, which allows remote attackers to bypass the intended restrictions of an extension that only implements one of these blocks.

    • Update to 1:1.19.6-1
    Published Updated
  7. CVE-2013-4302

    Not ratedEPSS 1.99%Fix available

    CVE-2013-4302

    (1) ApiBlock.php, (2) ApiCreateAccount.php, (3) ApiLogin.php, (4) ApiMain.php, (5) ApiQueryDeletedrevs.php, (6) ApiTokens.php, and (7) ApiUnblock.php in includes/api/ in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 allow remote attackers to obtain CSRF tokens and bypass the cross-site request forgery (CSRF) protection mechanism via a JSONP request to wiki/api.php.

    • Update to 1:1.19.8+dfsg-1
    Published Updated
  8. CVE-2013-4301

    Not ratedEPSS 2.08%Fix available

    CVE-2013-4301

    includes/resourceloader/ResourceLoaderContext.php in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 allows remote attackers to obtain sensitive information via a "<" (open angle bracket) character in the lang parameter to w/load.php, which reveals the installation path in an error message.

    • Update to 1:1.19.8+dfsg-1
    Published Updated
  9. CVE-2012-1582

    Not ratedEPSS 2.38%Fix available

    CVE-2012-1582

    Cross-site scripting (XSS) vulnerability in the wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to inject arbitrary web script or HTML via a crafted page with "forged strip item markers," as demonstrated using the CharInsert extension.

    • Update to 1:1.15.5-9
    Published Updated
  10. CVE-2012-2698

    Not ratedEPSS 4.95%Public exploitFix available

    CVE-2012-2698

    Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.

    • Update to 1:1.19.1-1
    Published Updated
  11. CVE-2011-4361

    Not ratedEPSS 2.23%Fix available

    CVE-2011-4361

    MediaWiki before 1.17.1 does not check for read permission before handling action=ajax requests, which allows remote attackers to obtain sensitive information by (1) leveraging the SpecialUpload::ajaxGetExistsWarning function, or by (2) leveraging an extension, as demonstrated by the CategoryTree, ExtTab, and InlineEditor extensions.

    • Update to 1:1.15.5-4
    Published Updated
  12. CVE-2011-1587

    Not ratedEPSS 1.71%Fix available

    CVE-2011-1587

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.

    • Update to 1:1.15.5-5
    Published Updated
  13. CVE-2011-1579

    Not ratedEPSS 1.92%Fix available

    CVE-2011-1579

    The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

    • Update to 1:1.15.5-5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →