p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 5

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 351

  1. CVE-2018-20151

    High · CVSS 7.5EPSS 5.78%Fix available

    CVE-2018-20151

    In WordPress before 4.9.9 and 5.x before 5.0.1, the user-activation page could be read by a search engine's web crawler if an unusual configuration were chosen. The search engine could then index and display a user's e-mail address and (rarely) the password that was generated by default.

    • Update to 5.0.1+dfsg1-1
    Published Updated
  2. CVE-2018-20148

    Critical · CVSS 9.8EPSS 26.82%Fix available

    CVE-2018-20148

    In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call. This is caused by mishandling of serialized data at phar:// URLs in the wp_get_attachment_thumb_file function in wp-includes/post.php.

    • Update to 5.0.1+dfsg1-1
    Published Updated
  3. CVE-2017-1000600

    High · CVSS 8.8EPSS 3.8%Fix available

    CVE-2017-1000600

    WordPress version <4.9 contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code execution. This attack appears to be exploitable via thumbnail upload by an authenticated user and may require additional plugins in order to be exploited however this has not been confirmed at this time. This issue appears to have been partially, but not completely fixed in WordPress 4.9

    • Update to 4.9.1+dfsg-1
    Published Updated
  4. CVE-2018-14028

    High · CVSS 7.2EPSS 15.17%No fix published

    CVE-2018-14028

    In WordPress 4.9.7, plugins uploaded via the admin area are not verified as being ZIP files. This allows for PHP files to be uploaded. Once a PHP file is uploaded, the plugin extraction fails, but the PHP file remains in a predictable wp-content/uploads location, allowing for an attacker to then execute the file. This represents a security risk in limited scenarios where an attacker (who does have the required capabilities for plugin uploads) cannot simply place arbitrary PHP code into a valid plugin ZIP file and upload that plugin, because a machine's wp-content/plugins directory permissions were set up to block all new plugins.

    Published Updated
  5. CVE-2018-12895

    High · CVSS 8.8EPSS 62.16%Public exploitFix available

    CVE-2018-12895

    WordPress through 4.9.6 allows Author users to execute arbitrary code by leveraging directory traversal in the wp-admin/post.php thumb parameter, which is passed to the PHP unlink function and can delete the wp-config.php file. This is related to missing filename validation in the wp-includes/post.php wp_delete_attachment function. The attacker must have capabilities for files and posts that are normally available only to the Author, Editor, and Administrator roles. The attack methodology is to delete wp-config.php and then launch a new installation process to increase the attacker's privileges.

    • Update to 4.9.7+dfsg1-1
    Published Updated
  6. CVE-2012-6707

    High · CVSS 7.5EPSS 1.11%No fix published

    CVE-2012-6707

    WordPress through 4.8.2 uses a weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values. NOTE: the approach to changing this may not be fully compatible with certain use cases, such as migration of a WordPress site from a web host that uses a recent PHP version to a different web host that uses PHP 5.2. These use cases are plausible (but very unlikely) based on statistics showing widespread deployment of WordPress with obsolete PHP versions.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →