p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities · Page 13

Vulnerabilities published for apache2 in the last 30 days: 20. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 266

  1. CVE-2002-0840

    Not ratedEPSS 95.09%Public exploitFix available

    CVE-2002-0840

    Cross-site scripting (XSS) vulnerability in the default error page of Apache 2.0 before 2.0.43, and 1.3.x up to 1.3.26, when UseCanonicalName is "Off" and support for wildcard DNS is present, allows remote attackers to execute script as other web page visitors via the Host: header, a different vulnerability than CAN-2002-1157.

    • Update to 2.0.43-1
    Published Updated
  2. CVE-2004-0493

    Not ratedEPSS 84.78%Public exploitFix available

    CVE-2004-0493

    The ap_get_mime_headers_core function in Apache httpd 2.0.49 allows remote attackers to cause a denial of service (memory exhaustion), and possibly an integer signedness error leading to a heap-based buffer overflow on 64 bit systems, via long header lines with large numbers of space or tab characters.

    • Update to 2.0.50-1
    Published Updated
  3. CVE-2003-0192

    Not ratedEPSS 5.99%Fix available

    CVE-2003-0192

    Apache 2 before 2.0.47, and certain versions of mod_ssl for Apache 1.3, do not properly handle "certain sequences of per-directory renegotiations and the SSLCipherSuite directive being used to upgrade from a weak ciphersuite to a strong one," which could cause Apache to use the weak ciphersuite.

    • Update to 2.0.47
    Published Updated
  4. CVE-2003-0245

    Not ratedEPSS 63.46%Public exploitFix available

    CVE-2003-0245

    Vulnerability in the apr_psprintf function in the Apache Portable Runtime (APR) library for Apache 2.0.37 through 2.0.45 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via long strings, as demonstrated using XML objects to mod_dav, and possibly other vectors.

    • Update to 2.0.46
    Published Updated
  5. CVE-2003-0189

    Not ratedEPSS 15.12%Fix available

    CVE-2003-0189

    The authentication module for Apache 2.0.40 through 2.0.45 on Unix does not properly handle threads safely when using the crypt_r or crypt functions, which allows remote attackers to cause a denial of service (failed Basic authentication with valid usernames and passwords) when a threaded MPM is used.

    • Update to 2.0.46
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →