p PatchFirst

PatchFirst · Latest vulnerabilities

gnutls28 vulnerabilities · Page 3

Vulnerabilities published for gnutls28 in the last 30 days: 6. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 70

  1. CVE-2018-16868

    Medium · CVSS 4.7EPSS 0.58%Fix available

    CVE-2018-16868

    A Bleichenbacher type side-channel based padding oracle attack was found in the way gnutls handles verification of RSA decrypted PKCS#1 v1.5 data. An attacker who is able to run process on the same physical core as the victim process, could use this to extract plaintext or in some cases downgrade any TLS connections to a vulnerable server.

    • Update to 3.6.5-2
    Published Updated
  2. CVE-2017-5334

    Critical · CVSS 9.8EPSS 32.75%Fix available

    CVE-2017-5334

    Double free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via crafted policy language information in an X.509 certificate with a Proxy Certificate Information extension.

    • Update to 3.5.8-1
    Published Updated
  3. CVE-2016-7444

    High · CVSS 7.5EPSS 2.44%Fix available

    CVE-2016-7444

    The gnutls_ocsp_resp_check_crt function in lib/x509/ocsp.c in GnuTLS before 3.4.15 and 3.5.x before 3.5.4 does not verify the serial length of an OCSP response, which might allow remote attackers to bypass an intended certificate validation mechanism via vectors involving trailing bytes left by gnutls_malloc.

    • Update to 3.5.3-4
    Published Updated
  4. CVE-2015-7575

    Medium · CVSS 5.9EPSS 2.9%Fix available

    CVE-2015-7575

    Mozilla Network Security Services (NSS) before 3.20.2, as used in Mozilla Firefox before 43.0.2 and Firefox ESR 38.x before 38.5.2, does not reject MD5 signatures in Server Key Exchange messages in TLS 1.2 Handshake Protocol traffic, which makes it easier for man-in-the-middle attackers to spoof servers by triggering a collision.

    • Update to 3.3.15-1
    Published Updated
  5. CVE-2014-8564

    Not ratedEPSS 3.28%Fix available

    CVE-2014-8564

    The _gnutls_ecc_ansi_x963_export function in gnutls_ecc.c in GnuTLS 3.x before 3.1.28, 3.2.x before 3.2.20, and 3.3.x before 3.3.10 allows remote attackers to cause a denial of service (out-of-bounds write) via a crafted (1) Elliptic Curve Cryptography (ECC) certificate or (2) certificate signing requests (CSR), related to generating key IDs.

    • Update to 3.3.8-4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →