p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 11

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 295

  1. CVE-2015-8004

    Not ratedEPSS 1.72%Fix available

    CVE-2015-8004

    MediaWiki before 1.23.11, 1.24.x before 1.24.4, and 1.25.x before 1.25.3 does not properly restrict access to revisions, which allows remote authenticated users with the viewsuppressed user right to remove revision suppressions via a crafted revisiondelete action, which returns a valid a change form.

    • Update to 1:1.25.5-1
    Published Updated
  2. CVE-2015-6730

    Not ratedEPSS 2.01%Fix available

    CVE-2015-6730

    Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.23.10, 1.24.x before 1.24.3, and 1.25.x before 1.25.2 allows remote attackers to inject arbitrary web script or HTML via the f parameter, which is not properly handled in an error page, related to "ForeignAPI images."

    • Update to 1:1.25.5-1
    Published Updated
  3. CVE-2015-2942

    Not ratedEPSS 2.81%Fix available

    CVE-2015-2942

    MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM, allows remote attackers to cause a denial of service (CPU and memory consumption) via a large number of nested entity references in an (1) SVG file or (2) XMP metadata in a PDF file, aka a "billion laughs attack," a different vulnerability than CVE-2015-2937.

    • Update to 1:1.19.20+dfsg-2.3
    Published Updated
  4. CVE-2015-2941

    Not ratedEPSS 2.1%Fix available

    CVE-2015-2941

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM, allows remote attackers to inject arbitrary web script or HTML via an invalid parameter in a wddx format request to api.php, which is not properly handled in an error message, related to unsafe calls to wddx_serialize_value.

    • Update to 1:1.19.20+dfsg-2.3
    Published Updated
  5. CVE-2015-2937

    Not ratedEPSS 2.69%Fix available

    CVE-2015-2937

    MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM or Zend PHP, allows remote attackers to cause a denial of service ("quadratic blowup" and memory consumption) via an XML file containing an entity declaration with long replacement text and many references to this entity, a different vulnerability than CVE-2015-2942.

    • Update to 1:1.19.20+dfsg-2.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →