p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 10

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 295

  1. CVE-2016-6336

    Medium · CVSS 6.5EPSS 0.96%Fix available

    CVE-2016-6336

    MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote authenticated users with undelete permissions to bypass intended suppressrevision and deleterevision restrictions and remove the revision deletion status of arbitrary file revisions by using Special:Undelete.

    • Update to 1:1.27.1-1
    Published Updated
  2. CVE-2016-6334

    Medium · CVSS 6.1EPSS 1.12%Fix available

    CVE-2016-6334

    Cross-site scripting (XSS) vulnerability in the Parser::replaceInternalLinks2 method in MediaWiki before 1.23.15, 1.26.x before 1.26.4, and 1.27.x before 1.27.1 allows remote attackers to inject arbitrary web script or HTML via vectors involving replacement of percent encoding in unclosed internal links.

    • Update to 1:1.27.1-1
    Published Updated
  3. CVE-2015-8628

    Medium · CVSS 5.3EPSS 1.41%Fix available

    CVE-2015-8628

    The (1) Special:MyPage, (2) Special:MyTalk, (3) Special:MyContributions, (4) Special:MyUploads, and (5) Special:AllMyUploads pages in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1 allow remote attackers to obtain sensitive user login information via crafted links combined with page view statistics.

    • Update to 1:1.25.5-1
    Published Updated
  4. CVE-2015-8627

    Medium · CVSS 5.3EPSS 1.36%Fix available

    CVE-2015-8627

    MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1 do not properly normalize IP addresses containing zero-padded octets, which might allow remote attackers to bypass intended access restrictions by using an IP address that was not supposed to have been allowed.

    • Update to 1:1.25.5-1
    Published Updated
  5. CVE-2015-8624

    High · CVSS 8.8EPSS 0.75%Fix available

    CVE-2015-8624

    The User::matchEditToken function in includes/User.php in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1 does not perform token comparison in constant time before determining if a debugging message should be logged, which allows remote attackers to guess the edit token and bypass CSRF protection via a timing attack, a different vulnerability than CVE-2015-8623.

    • Update to 1:1.25.5-1
    Published Updated
  6. CVE-2015-8623

    High · CVSS 8.8EPSS 0.73%Fix available

    CVE-2015-8623

    The User::matchEditToken function in includes/User.php in MediaWiki before 1.23.12 and 1.24.x before 1.24.5 does not perform token comparison in constant time before returning, which allows remote attackers to guess the edit token and bypass CSRF protection via a timing attack, a different vulnerability than CVE-2015-8624.

    • Update to 1:1.25.5-1
    Published Updated
  7. CVE-2015-8622

    Medium · CVSS 6.1EPSS 1.48%Fix available

    CVE-2015-8622

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.23.12, 1.24.x before 1.24.5, 1.25.x before 1.25.4, and 1.26.x before 1.26.1, when is configured with a relative URL, allows remote authenticated users to inject arbitrary web script or HTML via wikitext, as demonstrated by a wikilink to a page named "javascript:alert('XSS!')."

    • Update to 1:1.25.5-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →