p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 12

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 295

  1. CVE-2014-9277

    Not ratedEPSS 1.97%Fix available

    CVE-2014-9277

    The wfMangleFlashPolicy function in OutputHandler.php in MediaWiki before 1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7 allows remote attackers to conduct PHP object injection attacks via a crafted string containing <cross-domain-policy> in a PHP format request, which causes the string length to change when converting the request to <NOT-cross-domain-policy>.

    • Update to 1:1.19.20+dfsg-2.1
    Published Updated
  2. CVE-2014-7295

    Not ratedEPSS 1.57%Fix available

    CVE-2014-7295

    The (1) Special:Preferences and (2) Special:UserLogin pages in MediaWiki before 1.19.20, 1.22.x before 1.22.12 and 1.23.x before 1.23.5 allows remote authenticated users to conduct cross-site scripting (XSS) attacks or have unspecified other impact via crafted CSS, as demonstrated by modifying MediaWiki:Common.css.

    • Update to 1:1.19.20+dfsg-1
    Published Updated
  3. CVE-2014-5241

    Not ratedEPSS 0.84%Fix available

    CVE-2014-5241

    The JSONP endpoint in includes/api/ApiFormatJson.php in MediaWiki before 1.19.18, 1.20.x through 1.22.x before 1.22.9, and 1.23.x before 1.23.2 accepts certain long callback values and does not restrict the initial bytes of a JSONP response, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks, and obtain sensitive information, via a crafted OBJECT element with SWF content consistent with a restricted character set.

    • Update to 1:1.19.18+dfsg-0.1
    Published Updated
  4. CVE-2013-6472

    Not ratedEPSS 1.27%Fix available

    CVE-2013-6472

    MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to obtain information about deleted page via the (1) log API, (2) enhanced RecentChanges, and (3) user watchlists.

    • Update to 1:1.19.10+dfsg-1
    Published Updated
  5. CVE-2013-6452

    Not ratedEPSS 1.01%Fix available

    CVE-2013-6452

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via crafted XSL in an SVG file.

    • Update to 1:1.19.10+dfsg-1
    Published Updated
  6. CVE-2014-2665

    Not ratedEPSS 1.06%Fix available

    CVE-2014-2665

    includes/specials/SpecialChangePassword.php in MediaWiki before 1.19.14, 1.20.x and 1.21.x before 1.21.8, and 1.22.x before 1.22.5 does not properly handle a correctly authenticated but unintended login attempt, which makes it easier for remote authenticated users to obtain sensitive information by arranging for a victim to login to the attacker's account, as demonstrated by tracking the victim's activity, related to a "login CSRF" issue.

    • Update to 1:1.19.14+dfsg-1
    Published Updated
  7. CVE-2014-2243

    Not ratedEPSS 1.55%Fix available

    CVE-2014-2243

    includes/User.php in MediaWiki before 1.19.12, 1.20.x and 1.21.x before 1.21.6, and 1.22.x before 1.22.3 terminates validation of a user token upon encountering the first incorrect character, which makes it easier for remote attackers to obtain access via a brute-force attack that relies on timing differences in responses to incorrect token guesses.

    • Update to 1:1.19.12+dfsg-1
    Published Updated
  8. CVE-2014-2242

    Not ratedEPSS 2.44%Fix available

    CVE-2014-2242

    includes/upload/UploadBase.php in MediaWiki before 1.19.12, 1.20.x and 1.21.x before 1.21.6, and 1.22.x before 1.22.3 does not prevent use of invalid namespaces in SVG files, which allows remote attackers to conduct cross-site scripting (XSS) attacks via an SVG upload, as demonstrated by use of a W3C XHTML namespace in conjunction with an IFRAME element.

    • Update to 1:1.19.12+dfsg-1
    Published Updated
  9. CVE-2014-1610

    Not ratedEPSS 42.78%Public exploitFix available

    CVE-2014-1610

    MediaWiki 1.22.x before 1.22.2, 1.21.x before 1.21.5, and 1.19.x before 1.19.11, when DjVu or PDF file upload support is enabled, allows remote attackers to execute arbitrary commands via shell metacharacters in (1) the page parameter to includes/media/DjVu.php; (2) the w parameter (aka width field) to thumb.php, which is not properly handled by includes/media/PdfHandler_body.php; and possibly unspecified vectors in (3) includes/media/Bitmap.php and (4) includes/media/ImageHandler.php.

    • Update to 1:1.19.11+dfsg-1
    Published Updated
  10. CVE-2013-4568

    Not ratedEPSS 2.1%Fix available

    CVE-2013-4568

    Incomplete blacklist vulnerability in Sanitizer::checkCss in MediaWiki before 1.19.9, 1.20.x before 1.20.8, and 1.21.x before 1.21.3 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain non-ASCII characters in CSS, as demonstrated using variations of "expression" containing (1) full width characters or (2) IPA extensions, which are converted and rendered by Internet Explorer.

    • Update to 1:1.19.8+dfsg-2.2
    Published Updated
  11. CVE-2013-2032

    Not ratedEPSS 2.51%Fix available

    CVE-2013-2032

    MediaWiki before 1.19.6 and 1.20.x before 1.20.5 does not allow extensions to prevent password changes without using both Special:PasswordReset and Special:ChangePassword, which allows remote attackers to bypass the intended restrictions of an extension that only implements one of these blocks.

    • Update to 1:1.19.6-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →