p PatchFirst

PatchFirst · Latest vulnerabilities

rails vulnerabilities · Page 6

Vulnerabilities published for rails in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 115

  1. CVE-2011-0447

    Not ratedEPSS 1.42%Fix available

    CVE-2011-0447

    Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.

    • Update to 2.3.11-0.1
    Published Updated
  2. CVE-2008-7248

    Not ratedEPSS 8.08%Public exploitFix available

    CVE-2008-7248

    Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

    • Update to 2.2.3-1
    Published Updated
  3. CVE-2009-4214

    Not ratedEPSS 3.02%Fix available

    CVE-2009-4214

    Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

    • Update to 2.2.3-2
    Published Updated
  4. CVE-2009-2422

    Critical · CVSS 9.8EPSS 3.38%Fix available

    CVE-2009-2422

    The example code for the digest authentication functionality (http_authentication.rb) in Ruby on Rails before 2.3.3 defines an authenticate_or_request_with_http_digest block that returns nil instead of false when the user does not exist, which allows context-dependent attackers to bypass authentication for applications that are derived from this example by sending an invalid username without a password.

    • Update to 2.3.5-1
    Published Updated
  5. CVE-2007-6077

    Not ratedEPSS 2.51%Fix available

    CVE-2007-6077

    The session fixation protection mechanism in cgi_process.rb in Rails 1.2.4, as used in Ruby on Rails, removes the :cookie_only attribute from the DEFAULT_SESSION_OPTIONS constant, which effectively causes cookie_only to be applied only to the first instantiation of CgiRequest, which allows remote attackers to conduct session fixation attacks. NOTE: this is due to an incomplete fix for CVE-2007-5380.

    • Update to 1.2.6-1
    Published Updated
  6. CVE-2007-5379

    Not ratedEPSS 3.97%Fix available

    CVE-2007-5379

    Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers and ActiveResource servers to determine the existence of arbitrary files and read arbitrary XML files via the Hash.from_xml (Hash#from_xml) method, which uses XmlSimple (XML::Simple) unsafely, as demonstrated by reading passwords from the Pidgin (Gaim) .purple/accounts.xml file.

    • Update to 1.2.5-1
    Published Updated
  7. CVE-2006-4112

    Not ratedEPSS 3.12%Fix available

    CVE-2006-4112

    Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute arbitrary Ruby code via a URL that is not properly handled in the routing code, which leads to a denial of service (application hang) or "data loss," a different vulnerability than CVE-2006-4111.

    • Update to 1.1.6-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →