p PatchFirst

PatchFirst · Latest vulnerabilities

samba vulnerabilities · Page 6

Vulnerabilities published for samba in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 205

  1. CVE-2018-10858

    Medium · CVSS 4.3EPSS 4.3%Fix available

    CVE-2018-10858

    A heap-buffer overflow was found in the way samba clients processed extra long filename in a directory listing. A malicious samba server could use this flaw to cause arbitrary code execution on a samba client. Samba versions before 4.6.16, 4.7.9 and 4.8.4 are vulnerable.

    • Update to 2:4.8.4+dfsg-1
    Published Updated
  2. CVE-2018-1140

    Medium · CVSS 6.5EPSS 10.84%Fix available

    CVE-2018-1140

    A missing input sanitization flaw was found in the implementation of LDP database used for the LDAP server. An attacker could use this flaw to cause a denial of service against a samba server, used as a Active Directory Domain Controller. All versions of Samba from 4.8.0 onwards are vulnerable

    • Update to 2:4.8.4+dfsg-1
    Published Updated
  3. CVE-2018-1139

    Medium · CVSS 5.4EPSS 3.1%Fix available

    CVE-2018-1139

    A flaw was found in the way samba before 4.7.9 and 4.8.4 allowed the use of weak NTLMv1 authentication even when NTLMv1 was explicitly disabled. A man-in-the-middle attacker could use this flaw to read the credential and other details passed between the samba server and client.

    • Update to 2:4.8.4+dfsg-1
    Published Updated
  4. CVE-2017-12151

    High · CVSS 7.4EPSS 4.1%Fix available

    CVE-2017-12151

    A flaw was found in the way samba client before samba 4.4.16, samba 4.5.14 and samba 4.6.8 used encryption with the max protocol set as SMB3. The connection could lose the requirement for signing and encrypting to any DFS redirects, allowing an attacker to read or alter the contents of the connection via a man-in-the-middle attack.

    • Update to 2:4.6.7+dfsg-2
    Published Updated
  5. CVE-2017-12163

    Medium · CVSS 4.1EPSS 7.59%Fix available

    CVE-2017-12163

    An information leak flaw was found in the way SMB1 protocol was implemented by Samba before 4.4.16, 4.5.x before 4.5.14, and 4.6.x before 4.6.8. A malicious client could use this flaw to dump server memory contents to a file on the samba share or to a shared printer, though the exact area of server memory cannot be controlled by the attacker.

    • Update to 2:4.6.7+dfsg-2
    Published Updated
  6. CVE-2018-1057

    High · CVSS 8.8EPSS 10.04%Fix available

    CVE-2018-1057

    On a Samba 4 AD DC the LDAP server in all versions of Samba from 4.0.0 onwards incorrectly validates permissions to modify passwords over LDAP allowing authenticated users to change any other users' passwords, including administrative users and privileged service accounts (eg Domain Controllers).

    • Update to 2:4.7.4+dfsg-2
    Published Updated
  7. CVE-2018-1050

    Medium · CVSS 4.3EPSS 6.51%Fix available

    CVE-2018-1050

    All versions of Samba from 4.0.0 onwards are vulnerable to a denial of service attack when the RPC spoolss service is configured to be run as an external daemon. Missing input sanitization checks on some of the input parameters to spoolss RPC calls could cause the print spooler service to crash.

    • Update to 2:4.7.4+dfsg-2
    Published Updated
  8. CVE-2017-11103

    High · CVSS 8.1EPSS 5.12%Fix available

    CVE-2017-11103

    Heimdal before 7.4 allows remote attackers to impersonate services with Orpheus' Lyre attacks because it obtains service-principal names in a way that violates the Kerberos 5 protocol specification. In _krb5_extract_ticket() the KDC-REP service name must be obtained from the encrypted version stored in 'enc_part' instead of the unencrypted version stored in 'ticket'. Use of the unencrypted version provides an opportunity for successful server impersonation and other attacks. NOTE: this CVE is only for Heimdal and other products that embed Heimdal code; it does not apply to other instances in which this part of the Kerberos 5 protocol specific

    • Update to 2:4.6.5+dfsg-4
    Published Updated
  9. CVE-2016-2126

    Medium · CVSS 6.5EPSS 6.59%Fix available

    CVE-2016-2126

    Samba version 4.0.0 up to 4.5.2 is vulnerable to privilege elevation due to incorrect handling of the PAC (Privilege Attribute Certificate) checksum. A remote, authenticated, attacker can cause the winbindd process to crash using a legitimate Kerberos ticket. A local service with access to the winbindd privileged pipe can cause winbindd to cache elevated access permissions.

    • Update to 2:4.5.2+dfsg-2
    Published Updated
  10. CVE-2016-2119

    High · CVSS 7.5EPSS 3.1%Fix available

    CVE-2016-2119

    libcli/smb/smbXcli_base.c in Samba 4.x before 4.2.14, 4.3.x before 4.3.11, and 4.4.x before 4.4.5 allows man-in-the-middle attackers to bypass a client-signing protection mechanism, and consequently spoof SMB2 and SMB3 servers, via the (1) SMB2_SESSION_FLAG_IS_GUEST or (2) SMB2_SESSION_FLAG_IS_NULL flag.

    • Update to 2:4.4.5+dfsg-1
    Published Updated
  11. CVE-2016-2114

    Medium · CVSS 5.9EPSS 2.68%Fix available

    CVE-2016-2114

    The SMB1 protocol implementation in Samba 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 does not recognize the "server signing = mandatory" setting, which allows man-in-the-middle attackers to spoof SMB servers by modifying the client-server data stream.

    • Update to 2:4.3.7+dfsg-1
    Published Updated
  12. CVE-2016-2112

    Medium · CVSS 5.9EPSS 9.42%Fix available

    CVE-2016-2112

    The bundled LDAP client library in Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 does not recognize the "client ldap sasl wrapping" setting, which allows man-in-the-middle attackers to perform LDAP protocol-downgrade attacks by modifying the client-server data stream.

    • Update to 2:4.3.7+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →