p PatchFirst

PatchFirst · Latest vulnerabilities

moodle/moodle vulnerabilities · Page 20

Vulnerabilities published for moodle/moodle in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 437

  1. CVE-2013-4942

    Medium · CVSS 5.3EPSS 1.19%Fix available

    CVE-2013-4942

    Cross-site scripting (XSS) vulnerability in flashuploader.swf in the Uploader component in Yahoo! YUI 3.5.0 through 3.9.1, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL.

    • Update to 2.2.11
    • Update to 2.3.8
    • Update to 2.4.5
    • Update to 2.5.1
    Published Updated
  2. CVE-2013-4941

    Medium · CVSS 5.3EPSS 1.19%Fix available

    CVE-2013-4941

    Cross-site scripting (XSS) vulnerability in uploader.swf in the Uploader component in Yahoo! YUI 3.2.0 through 3.9.1, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL.

    • Update to 2.2.11
    • Update to 2.3.8
    • Update to 2.4.5
    • Update to 2.5.1
    Published Updated
  3. CVE-2013-4940

    Medium · CVSS 5.3EPSS 1.49%Fix available

    CVE-2013-4940

    Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

    • Update to 2.2.11
    • Update to 2.3.8
    • Update to 2.4.5
    • Update to 2.5.1
    Published Updated
  4. CVE-2013-2083

    Not ratedEPSS 2.34%Fix available

    CVE-2013-2083

    The MoodleQuickForm class in lib/formslib.php in Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly handle a certain array-element syntax, which allows remote attackers to bypass intended form-data filtering via a crafted request.

    • Update to 2.2.10
    • Update to 2.3.7
    • Update to 2.4.4
    Published Updated
  5. CVE-2013-2080

    Not ratedEPSS 1.82%Fix available

    CVE-2013-2080

    The core_grade component in Moodle through 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly consider the existence of hidden grades, which allows remote authenticated users to obtain sensitive information by leveraging the student role and reading the Gradebook Overview report.

    • Update to 2.3.7
    • Update to 2.4.4
    Published Updated
  6. CVE-2013-1836

    Not ratedEPSS 1.91%Fix available

    CVE-2013-1836

    Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not properly manage privileges for WebDAV repositories, which allows remote authenticated users to read, modify, or delete arbitrary site-wide repositories by leveraging certain read access.

    • Update to 2.2.8
    • Update to 2.3.5
    • Update to 2.4.2
    Published Updated
  7. CVE-2013-1835

    Not ratedEPSS 1.71%Fix available

    CVE-2013-1835

    Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated administrators to obtain sensitive information from the external repositories of arbitrary users by leveraging the login_as feature.

    • Update to 2.2.8
    • Update to 2.3.5
    • Update to 2.4.2
    Published Updated
  8. CVE-2013-1833

    Not ratedEPSS 1.45%Fix available

    CVE-2013-1833

    Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted filename.

    • Update to 2.2.8
    • Update to 2.3.5
    • Update to 2.4.2
    Published Updated
  9. CVE-2013-1832

    Not ratedEPSS 1.12%Fix available

    CVE-2013-1832

    repository/webdav/lib.php in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 includes the WebDAV password in the configuration form, which allows remote authenticated administrators to obtain sensitive information by configuring an instance.

    • Update to 2.2.8
    • Update to 2.3.5
    • Update to 2.4.2
    Published Updated
  10. CVE-2013-1831

    Not ratedEPSS 1.6%Fix available

    CVE-2013-1831

    lib/setuplib.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote attackers to obtain sensitive information via an invalid request, which reveals the absolute path in an exception message.

    • Update to 2.2.8
    • Update to 2.3.5
    • Update to 2.4.2
    Published Updated
  11. CVE-2013-1830

    Not ratedEPSS 1.82%Fix available

    CVE-2013-1830

    user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the forceloginforprofiles setting, which allows remote attackers to obtain sensitive course-profile information by leveraging the guest role, as demonstrated by a Google search.

    • Update to 2.2.8
    • Update to 2.3.5
    • Update to 2.4.2
    Published Updated
  12. CVE-2012-6112

    Not ratedEPSS 2.29%Fix available

    CVE-2012-6112

    classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before 2.0.6.1 for TinyMCE, as used in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 and other products, does not properly handle control characters, which allows remote attackers to trigger arbitrary outbound HTTP requests via a crafted string.

    • Update to 2.1.10
    • Update to 2.2.7
    • Update to 2.3.4
    • Update to 2.4.1
    Published Updated
  13. CVE-2012-6099

    Not ratedEPSS 1.12%Fix available

    CVE-2012-6099

    The moodle1 backup converter in backup/converter/moodle1/lib.php in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 does not properly validate pathnames, which allows remote authenticated users to read arbitrary files by leveraging the backup-restoration feature.

    • Update to 2.1.10
    • Update to 2.2.7
    • Update to 2.3.4
    • Update to 2.4.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →