p PatchFirst

PatchFirst · Latest vulnerabilities

prestashop/prestashop vulnerabilities · Page 2

Vulnerabilities published for prestashop/prestashop in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 31

  1. CVE-2023-30838

    High · CVSS 8.6EPSS 1.04%Fix available

    PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method

    PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML

    • Update to 1.7.8.9
    • Update to 8.0.4
    Published Updated
  2. CVE-2023-30545

    High · CVSS 7.7EPSS 0.86%Fix available

    PrestaShop arbitrary file read vulnerability

    PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, it is possible for a user with access to the SQL Manager (Advanced Options -> Database) to arbitrarily read any file on the operating system when using SQL function `LOAD_FILE` in a `SELECT` request. This gives the user access to critical information. A patch is available in PrestaShop 8.0.4 and PS 1.7.8.9

    • Update to 1.7.8.9
    • Update to 8.0.4
    Published Updated
  3. CVE-2023-25170

    Medium · CVSS 5EPSS 0.22%Fix available

    PrestaShop has possible CSRF token fixation

    PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.

    • Update to 8.0.1
    Published Updated
  4. CVE-2022-46158

    Medium · CVSS 5.3EPSS 0.5%Fix available

    Potential Information exposure in the upload directory in PrestaShop

    PrestaShop is an open-source e-commerce solution. Versions prior to 1.7.8.8 did not properly restrict host filesystem access for users. Users may have been able to view the contents of the upload directory without appropriate permissions. This issue has been addressed and users are advised to upgrade to version 1.7.8.8. There are no known workarounds for this issue.

    • Update to 1.7.8.8
    Published Updated
  5. CVE-2022-31181

    Critical · CVSS 9.8EPSS 6.72%Public exploitFix available

    Remote code execution in prestashop

    PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.

    • Update to 1.7.8.7
    Published Updated
  6. CVE-2022-21686

    Critical · CVSS 9EPSS 1.79%Fix available

    Server Side Twig Template Injection in PrestaShop

    PrestaShop is an Open Source e-commerce platform. Starting with version 1.7.0.0 and ending with version 1.7.8.3, an attacker is able to inject twig code inside the back office when using the legacy layout. The problem is fixed in version 1.7.8.3. There are no known workarounds.

    • Update to 1.7.8.3
    Published Updated
  7. CVE-2019-11876

    Medium · CVSS 6.1EPSS 0.89%Fix available

    CVE-2019-11876

    In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation script/component is affected by Reflected XSS. Exploitation by a malicious actor requires the user to follow the initial stages of the setup (accepting terms and conditions) before executing the malicious link.

    • Update to 1.7.6.0
    Published Updated
  8. CVE-2018-20717

    High · CVSS 8.8EPSS 2.69%Fix available

    CVE-2018-20717

    In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.

    • Update to 1.7.2.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →