p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 3

Vulnerabilities published for ghostscript in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 78

  1. CVE-2019-14869

    High · CVSS 7.3EPSS 3.09%Fix available

    CVE-2019-14869

    A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.12
    Published Updated
  2. CVE-2019-14813

    High · CVSS 7.3EPSS 10.96%Fix available

    CVE-2019-14813

    A flaw was found in ghostscript, versions 9.x before 9.50, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.11
    Published Updated
  3. CVE-2019-14817

    High · CVSS 7.3EPSS 2.02%Fix available

    CVE-2019-14817

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdfexectoken and other procedures where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.11
    Published Updated
  4. CVE-2019-14811

    High · CVSS 7.3EPSS 3.75%Fix available

    CVE-2019-14811

    A flaw was found in, ghostscript versions prior to 9.50, in the .pdf_hook_DSC_Creator procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.11
    Published Updated
  5. CVE-2019-3839

    High · CVSS 7.3EPSS 1.71%Fix available

    CVE-2019-3839

    It was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.9
    Published Updated
  6. CVE-2019-3835

    High · CVSS 7.3EPSS 2.47%Fix available

    CVE-2019-3835

    It was found that the superexec operator was available in the internal dictionary in ghostscript before 9.27. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.8
    Published Updated
  7. CVE-2019-3838

    High · CVSS 7.3EPSS 2.47%Fix available

    CVE-2019-3838

    It was found that the forceput operator could be extracted from the DefineResource method in ghostscript before 9.27. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.8
    Published Updated
  8. USN-3866-3

    Not ratedFix available

    ghostscript regression

    USN-3866-2 fixed a regression in Ghostscript. The Ghostscript update introduced a new regression that resulted in certain pages being printed with a blue background. This update fixes the problem. Original advisory details: Tavis Ormandy discovered that Ghostscript incorrectly handled certain PostScript files. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use this issue to access arbitrary files, execute arbitrary code, or cause a denial of service.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.7
    Published Updated
  9. USN-3866-2

    Not ratedFix available

    ghostscript regression

    USN-3866-1 fixed vulnerabilities in Ghostscript. The new Ghostscript version introduced a regression when printing certain page sizes. This update fixes the problem. Original advisory details: Tavis Ormandy discovered that Ghostscript incorrectly handled certain PostScript files. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use this issue to access arbitrary files, execute arbitrary code, or cause a denial of service.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.5
    Published Updated
  10. CVE-2018-19134

    High · CVSS 7.8EPSS 2.87%Fix available

    CVE-2018-19134

    In Artifex Ghostscript through 9.25, the setpattern operator did not properly validate certain types. A specially crafted PostScript document could exploit this to crash Ghostscript or, possibly, execute arbitrary code in the context of the Ghostscript process. This is a type confusion issue because of failure to check whether the Implementation of a pattern dictionary was a structure type.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.1
    Published Updated
  11. USN-3831-2

    Not ratedFix available

    ghostscript regression

    USN-3831-1 fixed vulnerabilities in Ghostscript. Ghostscript 9.26 introduced a regression when used with certain options. This update fixes the problem. Original advisory details: It was discovered that Ghostscript contained multiple security issues. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use these issues to access arbitrary files, execute arbitrary code, or cause a denial of service.

    • Update to 9.26~dfsg+0-0ubuntu0.18.04.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →