p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 13

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 295

  1. CVE-2013-4302

    Not ratedEPSS 1.99%Fix available

    CVE-2013-4302

    (1) ApiBlock.php, (2) ApiCreateAccount.php, (3) ApiLogin.php, (4) ApiMain.php, (5) ApiQueryDeletedrevs.php, (6) ApiTokens.php, and (7) ApiUnblock.php in includes/api/ in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 allow remote attackers to obtain CSRF tokens and bypass the cross-site request forgery (CSRF) protection mechanism via a JSONP request to wiki/api.php.

    • Update to 1:1.19.8+dfsg-1
    Published Updated
  2. CVE-2013-4301

    Not ratedEPSS 2.08%Fix available

    CVE-2013-4301

    includes/resourceloader/ResourceLoaderContext.php in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 allows remote attackers to obtain sensitive information via a "<" (open angle bracket) character in the lang parameter to w/load.php, which reveals the installation path in an error message.

    • Update to 1:1.19.8+dfsg-1
    Published Updated
  3. CVE-2012-1582

    Not ratedEPSS 2.38%Fix available

    CVE-2012-1582

    Cross-site scripting (XSS) vulnerability in the wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to inject arbitrary web script or HTML via a crafted page with "forged strip item markers," as demonstrated using the CharInsert extension.

    • Update to 1:1.15.5-9
    Published Updated
  4. CVE-2012-2698

    Not ratedEPSS 4.95%Public exploitFix available

    CVE-2012-2698

    Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.

    • Update to 1:1.19.1-1
    Published Updated
  5. CVE-2011-4361

    Not ratedEPSS 2.23%Fix available

    CVE-2011-4361

    MediaWiki before 1.17.1 does not check for read permission before handling action=ajax requests, which allows remote attackers to obtain sensitive information by (1) leveraging the SpecialUpload::ajaxGetExistsWarning function, or by (2) leveraging an extension, as demonstrated by the CategoryTree, ExtTab, and InlineEditor extensions.

    • Update to 1:1.15.5-4
    Published Updated
  6. CVE-2011-1587

    Not ratedEPSS 1.71%Fix available

    CVE-2011-1587

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.

    • Update to 1:1.15.5-5
    Published Updated
  7. CVE-2011-1579

    Not ratedEPSS 1.92%Fix available

    CVE-2011-1579

    The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

    • Update to 1:1.15.5-5
    Published Updated
  8. CVE-2011-1578

    Not ratedEPSS 2.59%Fix available

    CVE-2011-1578

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.3, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html at the end of the query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.

    • Update to 1:1.15.5-5
    Published Updated
  9. CVE-2010-1648

    Not ratedEPSS 0.61%Fix available

    CVE-2010-1648

    Cross-site request forgery (CSRF) vulnerability in the login interface in MediaWiki 1.15 before 1.15.4 and 1.16 before 1.16 beta 3 allows remote attackers to hijack the authentication of users for requests that (1) create accounts or (2) reset passwords, related to the Special:Userlogin form.

    • Update to 1:1.15.4-1
    Published Updated
  10. CVE-2010-1150

    Not ratedEPSS 1.3%Fix available

    CVE-2010-1150

    MediaWiki before 1.15.3, and 1.6.x before 1.16.0beta2, does not properly handle a correctly authenticated but unintended login attempt, which makes it easier for remote authenticated users to conduct phishing attacks by arranging for a victim to login to the attacker's account and then execute a crafted user script, related to a "login CSRF" issue.

    • Update to 1:1.15.3-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →