p PatchFirst

PatchFirst · Latest vulnerabilities

poppler vulnerabilities · Page 5

Vulnerabilities published for poppler in the last 30 days: 3. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 141

  1. CVE-2017-2820

    High · CVSS 8.8EPSS 4.42%No fix published

    CVE-2017-2820

    An exploitable integer overflow vulnerability exists in the JPEG 2000 image parsing functionality of freedesktop.org Poppler 0.53.0. A specially crafted PDF file can lead to an integer overflow causing out of bounds memory overwrite on the heap resulting in potential arbitrary code execution. To trigger this vulnerability, a victim must open the malicious PDF in an application using this library.

    Published Updated
  2. CVE-2017-2818

    High · CVSS 7.5EPSS 1.98%No fix published

    CVE-2017-2818

    An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted PDF can cause an overly large number of color components during image rendering, resulting in heap corruption. An attacker controlled PDF file can be used to trigger this vulnerability.

    Published Updated
  3. CVE-2017-2814

    High · CVSS 7.5EPSS 2.95%No fix published

    CVE-2017-2814

    An exploitable heap overflow vulnerability exists in the image rendering functionality of Poppler 0.53.0. A specifically crafted pdf can cause an image resizing after allocation has already occurred, resulting in heap corruption which can lead to code execution. An attacker controlled PDF file can be used to trigger this vulnerability.

    Published Updated
  4. CVE-2015-8868

    High · CVSS 7.8EPSS 4.56%Fix available

    CVE-2015-8868

    Heap-based buffer overflow in the ExponentialFunction::ExponentialFunction function in Poppler before 0.40.0 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via an invalid blend mode in the ExtGState dictionary in a crafted PDF document.

    • Update to 0.38.0-3
    Published Updated
  5. CVE-2010-3704

    Not ratedEPSS 3.6%Fix available

    CVE-2010-3704

    The FoFiType1::parse function in fofi/FoFiType1.cc in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a PDF file with a crafted PostScript Type1 font that contains a negative array index, which bypasses input validation and triggers memory corruption.

    • Update to 0.12.4-1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →