p PatchFirst

PatchFirst · Latest vulnerabilities

spip vulnerabilities · Page 3

Vulnerability published for spip in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 80

  1. CVE-2021-44120

    Medium · CVSS 5.4EPSS 0.67%Fix available

    CVE-2021-44120

    SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability in ecrire/public/interfaces.php, adding the function safehtml to the vulnerable fields. An editor is able to modify his personal information. If the editor has an article written and available, when a user goes to the public site and wants to read the author's information, the malicious code will be executed. The "Who are you" and "Website Name" fields are vulnerable.

    • Update to 3.2.12-1
    Published Updated
  2. CVE-2021-44118

    Medium · CVSS 5.4EPSS 0.77%Fix available

    CVE-2021-44118

    SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

    • Update to 3.2.12-1
    Published Updated
  3. CVE-2016-7980

    High · CVSS 8.8EPSS 4.12%Public exploitFix available

    CVE-2016-7980

    Cross-site request forgery (CSRF) vulnerability in ecrire/exec/valider_xml.php in SPIP 3.1.2 and earlier allows remote attackers to hijack the authentication of administrators for requests that execute the XML validator on a local file via a crafted valider_xml request. NOTE: this issue can be combined with CVE-2016-7998 to execute arbitrary PHP code.

    • Update to 3.1.3-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →