p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 96

Vulnerabilities published for PHP in the last 30 days: 223. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2025-46556

    Medium · CVSS 6.5EPSS 0.41%Fix available

    MantisBT is Vulnerable to Denial-of-Service (DoS) attack via Excessive Note Length

    Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.27.1 and below allow attackers to permanently corrupt issue activity logs by submitting extremely long notes (tested with 4,788,761 characters) due to a lack of server-side validation of note length. Once such a note is added, the activity stream UI fails to render; therefore, new notes cannot be displayed, effectively breaking all future collaboration on the issue. This issue is fixed in version 2.27.2.

    • Update to 2.27.2
    Published Updated
  2. CVE-2025-64112

    High · CVSS 8EPSS 0.3%Fix available

    Statmatic vulnerable to Stored Cross-Site Scripting

    Statmatic is a Laravel and Git powered content management system (CMS). Stored XSS vulnerabilities in Collections and Taxonomies allow authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. This vulnerability is fixed in 5.22.1.

    • Update to 5.22.1
    Published Updated
  3. CVE-2025-12466

    High · CVSS 7.5EPSS 0.36%Fix available

    Simple OAuth (OAuth2) & OpenID Connect - Critical - Access bypass - SA-CONTRIB-2025-114

    Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Simple OAuth (OAuth2) & OpenID Connect allows Authentication Bypass.This issue affects Simple OAuth (OAuth2) & OpenID Connect: from 6.0.0 before 6.0.7.

    • Update to 6.0.7
    Published Updated
  4. CVE-2025-12083

    Medium · CVSS 6.1EPSS 0.2%Fix available

    CivicTheme Design System - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-113

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CivicTheme Design System allows Cross-Site Scripting (XSS).This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.

    • Update to 1.12.0
    Published Updated
  5. CVE-2025-10929

    Medium · CVSS 5.3EPSS 0.3%Fix available

    Reverse Proxy Header - Less critical - Access bypass - SA-CONTRIB-2025-111

    Improper Validation of Consistency within Input vulnerability in Drupal Reverse Proxy Header allows Manipulating User-Controlled Variables.This issue affects Reverse Proxy Header: from 0.0.0 before 1.1.2.

    • Update to 1.1.2
    Published Updated
  6. CVE-2025-10931

    Low · CVSS 3.8EPSS 0.2%Fix available

    Umami Analytics - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-109

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Umami Analytics allows Cross-Site Scripting (XSS).This issue affects Umami Analytics: from 0.0.0 before 1.0.1.

    • Update to 1.0.1
    Published Updated
  7. CVE-2025-10927

    Medium · CVSS 6.1EPSS 0.19%Fix available

    Plausible tracking - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-107

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Plausible tracking allows Cross-Site Scripting (XSS).This issue affects Plausible tracking: from 0.0.0 before 1.0.2.

    • Update to 1.0.2
    Published Updated
  8. CVE-2025-62798

    Medium · CVSS 5.4EPSS 0.22%Fix available

    Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax

    Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .

    • Update to 9.11.1
    Published Updated
  9. CVE-2025-62796

    Medium · CVSS 5.8EPSS 0.29%Fix available

    PrivateBin persistent HTML injection in attachment filename enables redirect and defacement

    PrivateBin is an online pastebin where the server has zero knowledge of pasted data. Versions 1.7.7 through 2.0.1 allow persistent HTML injection via the unsanitized attachment filename (attachment_name) when attachments are enabled. An attacker can modify attachment_name before encryption so that, after decryption, arbitrary HTML is inserted unescaped into the page near the file size hint, enabling redirect (e.g., meta refresh) and site defacement and related phishing attacks. Script execution is normally blocked by the recommended Content Security Policy, limiting confidentiality impact. The issue was introduced in 1.7.7 and fixed in 2.0.2.

    • Update to 2.0.2
    Published Updated
  10. CVE-2025-62401

    Medium · CVSS 5.4EPSS 0.22%Fix available

    Moodle: possible to bypass timer in timed assignments

    An issue in Moodle’s timed assignment feature allowed students to bypass the time restriction, potentially giving them more time than allowed to complete an assessment.

    • Update to 4.1.21
    • Update to 4.4.11
    • Update to 4.5.7
    • Update to 5.0.3
    Published Updated
  11. CVE-2025-62400

    Medium · CVSS 4.3EPSS 0.27%Fix available

    Moodle: hidden group names visible to event creators

    Moodle exposed the names of hidden groups to users who had permission to create calendar events but not to view hidden groups. This could reveal private or restricted group information.

    • Update to 4.1.21
    • Update to 4.4.11
    • Update to 4.5.7
    • Update to 5.0.3
    Published Updated
  12. CVE-2025-62399

    High · CVSS 7.5EPSS 0.4%Fix available

    Moodle: password brute force risk when mobile/web services enabled

    Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.

    • Update to 4.1.21
    • Update to 4.4.11
    • Update to 4.5.7
    • Update to 5.0.3
    Published Updated
  13. CVE-2025-62394

    Medium · CVSS 4.3EPSS 0.23%Fix available

    Moodle: quiz notifications sent to suspended participants

    Moodle failed to verify enrolment status correctly when sending quiz notifications. As a result, suspended or inactive users might receive quiz-related messages, leaking limited course information.

    • Update to 4.5.7
    • Update to 5.0.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →