p PatchFirst

PatchFirst · Latest vulnerabilities

phpmyadmin vulnerabilities · Page 9

Vulnerabilities published for phpmyadmin in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 256

  1. CVE-2011-4780

    Not ratedEPSS 1.35%Fix available

    CVE-2011-4780

    Multiple cross-site scripting (XSS) vulnerabilities in libraries/display_export.lib.php in phpMyAdmin 3.4.x before 3.4.9 allow remote attackers to inject arbitrary web script or HTML via crafted URL parameters, related to the export panels in the (1) server, (2) database, and (3) table sections.

    • Update to 4:3.4.9-1
    Published Updated
  2. CVE-2011-4634

    Medium · CVSS 6.5EPSS 2.13%Fix available

    CVE-2011-4634

    Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted database name, related to the Database Synchronize panel; (2) a crafted database name, related to the Database rename panel; (3) a crafted SQL query, related to the table overview panel; (4) a crafted SQL query, related to the view creation dialog; (5) a crafted column type, related to the table search dialog; or (6) a crafted column type, related to the create index dialog.

    • Update to 4:3.4.8-1
    Published Updated
  3. CVE-2011-4107

    Medium · CVSS 6.5EPSS 12.68%Public exploitFix available

    CVE-2011-4107

    The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.

    • Update to 4:3.4.7.1-1
    Published Updated
  4. CVE-2011-2719

    Not ratedEPSS 2.43%Fix available

    CVE-2011-2719

    libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.

    • Update to 4:3.4.3.2-1
    Published Updated
  5. CVE-2011-2718

    Not ratedEPSS 1.68%Fix available

    CVE-2011-2718

    Multiple directory traversal vulnerabilities in the relational schema implementation in phpMyAdmin 3.4.x before 3.4.3.2 allow remote authenticated users to include and execute arbitrary local files via directory traversal sequences in an export type field, related to (1) libraries/schema/User_Schema.class.php and (2) schema_export.php.

    • Update to 4:3.4.3.2-1
    Published Updated
  6. CVE-2011-2508

    High · CVSS 8.7EPSS 1.91%Fix available

    CVE-2011-2508

    Directory traversal vulnerability in libraries/display_tbl.lib.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1, when a certain MIME transformation feature is enabled, allows remote authenticated users to include and execute arbitrary local files via a .. (dot dot) in a GLOBALS[mime_map][$meta->name][transformation] parameter.

    • Update to 4:3.4.3.1-1
    Published Updated
  7. CVE-2011-2507

    Not ratedEPSS 2.97%Fix available

    CVE-2011-2507

    libraries/server_synchronize.lib.php in the Synchronize implementation in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly quote regular expressions, which allows remote authenticated users to inject a PCRE e (aka PREG_REPLACE_EVAL) modifier, and consequently execute arbitrary PHP code, by leveraging the ability to modify the SESSION superglobal array.

    • Update to 4:3.4.3.1-1
    Published Updated
  8. CVE-2011-2506

    Not ratedEPSS 9.63%Public exploitFix available

    CVE-2011-2506

    setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of comment closing delimiters, which allows remote attackers to conduct static code injection attacks by leveraging the ability to modify the SESSION superglobal array.

    • Update to 4:3.4.3.1-1
    Published Updated
  9. CVE-2011-2505

    Not ratedEPSS 12.88%Public exploitFix available

    CVE-2011-2505

    libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

    • Update to 4:3.4.3.1-1
    Published Updated
  10. CVE-2011-0987

    Not ratedEPSS 2.73%Fix available

    CVE-2011-0987

    The PMA_Bookmark_get function in libraries/bookmark.lib.php in phpMyAdmin 2.11.x before 2.11.11.3, and 3.3.x before 3.3.9.2, does not properly restrict bookmark queries, which makes it easier for remote authenticated users to trigger another user's execution of a SQL query by creating a bookmark.

    • Update to 4:3.3.9.2-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →