p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 6

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 352

  1. CVE-2012-6707

    High · CVSS 7.5EPSS 1.11%Fix available

    CVE-2012-6707

    WordPress through 4.8.2 uses a weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values. NOTE: the approach to changing this may not be fully compatible with certain use cases, such as migration of a WordPress site from a web host that uses a recent PHP version to a different web host that uses PHP 5.2. These use cases are plausible (but very unlikely) based on statistics showing widespread deployment of WordPress with obsolete PHP versions.

    • Update to 6.8.1+dfsg1-1
    Published Updated
  2. CVE-2017-14990

    Medium · CVSS 6.5EPSS 2.3%Fix available

    CVE-2017-14990

    WordPress 4.8.2 stores cleartext wp_signups.activation_key values (but stores the analogous wp_users.user_activation_key values as hashes), which might make it easier for remote attackers to hijack unactivated user accounts by leveraging database read access (such as access gained through an unspecified SQL injection vulnerability).

    • Update to 4.8.2+dfsg-2
    Published Updated
  3. CVE-2017-8295

    Medium · CVSS 5.9EPSS 26.7%Public exploitFix available

    CVE-2017-8295

    WordPress through 4.7.4 relies on the Host HTTP header for a password-reset e-mail message, which makes it easier for remote attackers to reset arbitrary passwords by making a crafted wp-login.php?action=lostpassword request and then arranging for this message to bounce or be resent, leading to transmission of the reset key to a mailbox on an attacker-controlled SMTP server. This is related to problematic use of the SERVER_NAME variable in wp-includes/pluggable.php in conjunction with the PHP mail function. Exploitation is not achievable in all cases because it requires at least one of the following: (1) the attacker can prevent the victim fr

    • Update to 4.7.5+dfsg-2
    Published Updated
  4. CVE-2017-1001000

    High · CVSS 7.5EPSS 84.94%Public exploitFix available

    CVE-2017-1001000

    The register_routes function in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in the REST API in WordPress 4.7.x before 4.7.2 does not require an integer identifier, which allows remote attackers to modify arbitrary pages via a request for wp-json/wp/v2/posts followed by a numeric value and a non-numeric value, as demonstrated by the wp-json/wp/v2/posts/123?id=123helloworld URI.

    • Update to 4.7.2+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →