p PatchFirst

PatchFirst · Latest vulnerabilities

moodle/moodle vulnerabilities · Page 13

Vulnerabilities published for moodle/moodle in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 437

  1. CVE-2018-14631

    High · CVSS 8.8EPSS 2.08%Fix available

    CVE-2018-14631

    moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.

    • Update to 3.3.8
    • Update to 3.4.5
    • Update to 3.5.2
    Published Updated
  2. CVE-2018-14630

    High · CVSS 8.8EPSS 4.6%Fix available

    CVE-2018-14630

    moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.

    • Update to 3.1.14
    • Update to 3.3.8
    • Update to 3.4.5
    • Update to 3.5.2
    Published Updated
  3. CVE-2018-10891

    Medium · CVSS 6.3EPSS 2.06%Fix available

    CVE-2018-10891

    A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

    • Update to 3.1.13
    • Update to 3.2.10
    • Update to 3.3.7
    • Update to 3.4.4
    • Update to 3.5.1
    Published Updated
  4. CVE-2018-10890

    Medium · CVSS 4.3EPSS 2.05%Fix available

    CVE-2018-10890

    A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. It was possible for the core_course_get_categories web service to return hidden categories, which should be omitted when fetching course categories.

    • Update to 3.1.13
    • Update to 3.3.7
    • Update to 3.4.4
    • Update to 3.5.1
    Published Updated
  5. CVE-2018-1136

    Medium · CVSS 4.3EPSS 1.06%Fix available

    CVE-2018-1136

    An issue was discovered in Moodle 3.x. An authenticated user is allowed to add HTML blocks containing scripts to their Dashboard; this is normally not a security issue because a personal dashboard is visible to this user only. Through this security vulnerability, users can move such a block to other pages where they can be viewed by other users.

    • Update to 3.1.12
    • Update to 3.2.9
    • Update to 3.3.6
    • Update to 3.4.3
    Published Updated
  6. CVE-2018-1081

    Medium · CVSS 5.3EPSS 1.41%Fix available

    CVE-2018-1081

    A flaw was found in Moodle 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions. Unauthenticated users can trigger custom messages to admin via paypal enrol script. Paypal IPN callback script should only send error emails to admin after request origin was verified, otherwise admin email can be spammed.

    • Update to 3.1.11
    • Update to 3.2.8
    • Update to 3.3.5
    • Update to 3.4.2
    Published Updated
  7. CVE-2017-15110

    Medium · CVSS 4.3EPSS 1.16%Fix available

    CVE-2017-15110

    In Moodle 3.x, students can find out email addresses of other students in the same course. Using search on the Participants page, students could search email addresses of all participants regardless of email visibility. This allows enumerating and guessing emails of other students.

    • Update to 3.1.9
    • Update to 3.2.6
    • Update to 3.3.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →