p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 115

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2025-31688

    Medium · CVSS 6.8EPSS 0.19%Fix available

    Configuration Split - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-017

    Cross-Site Request Forgery (CSRF) vulnerability in Drupal Configuration Split allows Cross Site Request Forgery.This issue affects Configuration Split: from 0.0.0 before 1.10.0, from 2.0.0 before 2.0.2.

    • Update to 1.10.0
    • Update to 2.0.2
    Published Updated
  2. CVE-2025-31687

    Medium · CVSS 6.1EPSS 0.26%Fix available

    SpamSpan filter - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-016

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows Cross-Site Scripting (XSS).This issue affects SpamSpan filter: from 0.0.0 before 3.2.1.

    • Update to 3.2.1
    Published Updated
  3. CVE-2025-31683

    Medium · CVSS 6.8EPSS 0.18%Fix available

    Google Tag - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-012

    Cross-Site Request Forgery (CSRF) vulnerability in Drupal Google Tag allows Cross Site Request Forgery.This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.

    • Update to 1.8.0
    • Update to 2.0.8
    Published Updated
  4. CVE-2025-31682

    Medium · CVSS 4.8EPSS 0.24%Fix available

    Google Tag - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-011

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS).This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.

    • Update to 1.8.0
    • Update to 2.0.8
    Published Updated
  5. CVE-2025-31679

    Medium · CVSS 6.1EPSS 0.26%Fix available

    Ignition Error Pages - Critical - Cross Site Scripting - SA-CONTRIB-2025-007

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Ignition Error Pages allows Cross-Site Scripting (XSS).This issue affects Ignition Error Pages: from 0.0.0 before 1.0.4.

    • Update to 1.0.4
    Published Updated
  6. CVE-2025-31675

    Medium · CVSS 5.4EPSS 0.5%Fix available

    Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2025-004

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5. It also affects the Drupal 7 module from versions 7.x-1.0 through 7.x-1.12.

    • Update to 10.3.14
    • Update to 10.4.5
    • Update to 11.0.13
    • Update to 11.1.5
    Published Updated
  7. CVE-2025-31674

    High · CVSS 7.5EPSS 0.6%Fix available

    Drupal core - Moderately critical - Gadget Chain - SA-CORE-2025-003

    Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.

    • Update to 10.3.13
    • Update to 10.4.3
    • Update to 11.0.12
    • Update to 11.1.3
    Published Updated
  8. CVE-2025-31673

    Medium · CVSS 4.6EPSS 0.32%Fix available

    Drupal core - Moderately critical - Access bypass - SA-CORE-2025-002

    Incorrect Authorization vulnerability in Drupal Drupal core allows Forceful Browsing.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.

    • Update to 10.3.13
    • Update to 10.4.3
    • Update to 11.0.12
    • Update to 11.1.3
    Published Updated
  9. CVE-2025-3057

    Medium · CVSS 6.1EPSS 0.31%Fix available

    Drupal core - Critical - Cross site scripting - SA-CORE-2025-001

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.

    • Update to 10.3.13
    • Update to 10.4.3
    • Update to 11.0.12
    • Update to 11.1.3
    Published Updated
  10. CVE-2025-2967

    Medium · CVSS 5.1No fix published

    ConcreteCMS Cross-Site Scripting (XSS) via HTML Block Text Field

    A vulnerability was found in ConcreteCMS up to 9.3.9. It has been classified as problematic. This affects the function Save of the component HTML Block Handler. The manipulation of the argument content leads to HTML injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

    Published Updated
  11. CVE-2025-1861

    Medium · CVSS 6.3EPSS 0.86%Fix available

    Stream HTTP wrapper truncates redirect location to 1024 bytes

    In PHP from 8.1.* before 8.1.32, from 8.2.* before 8.2.28, from 8.3.* before 8.3.19, from 8.4.* before 8.4.5, when parsing HTTP redirect in the response to an HTTP request, there is currently limit on the location value size caused by limited size of the location buffer to 1024. However as per RFC9110, the limit is recommended to be 8000. This may lead to incorrect URL truncation and redirecting to a wrong location.

    • Update to 7.0.33-0ubuntu0.16.04.16+esm15
    • Update to 7.2.24-0ubuntu0.18.04.17+esm8
    • Update to 7.4.3-4ubuntu2.29
    • Update to 8.1.2-1ubuntu2.21
    • Update to 8.1.32
    • Update to 8.2.28
    • Update to 8.2.28-1~deb12u1
    • Update to 8.3.19
    • Update to 8.3.6-0ubuntu0.24.04.4
    • Update to 8.4.5
    • Update to 8.4.5-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →