p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 14

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 295

  1. CVE-2010-1190

    Not ratedEPSS 1.42%Fix available

    CVE-2010-1190

    thumb.php in MediaWiki before 1.15.2, when used with access-restriction mechanisms such as img_auth.php, does not check user permissions before providing scaled images, which allows remote attackers to bypass intended access restrictions and read private images via unspecified manipulations.

    • Update to 1:1.15.2-1
    Published Updated
  2. CVE-2009-0737

    Not ratedEPSS 1.48%Fix available

    CVE-2009-0737

    Multiple cross-site scripting (XSS) vulnerabilities in the web-based installer (config/index.php) in MediaWiki 1.6 before 1.6.12, 1.12 before 1.12.4, and 1.13 before 1.13.4, when the installer is in active use, allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    • Update to 1:1.14.0-1
    Published Updated
  3. CVE-2008-5688

    Not ratedEPSS 1.13%Fix available

    CVE-2008-5688

    MediaWiki 1.8.1, and other versions before 1.13.3, when the wgShowExceptionDetails variable is enabled, sometimes provides the full installation path in a debugging message, which might allow remote attackers to obtain sensitive information via unspecified requests that trigger an uncaught exception.

    • Update to 1:1.13.3-1
    Published Updated
  4. CVE-2008-5250

    Not ratedEPSS 1.07%Fix available

    CVE-2008-5250

    Cross-site scripting (XSS) vulnerability in MediaWiki before 1.6.11, 1.12.x before 1.12.2, and 1.13.x before 1.13.3, when Internet Explorer is used and uploads are enabled, or an SVG scripting browser is used and SVG uploads are enabled, allows remote authenticated users to inject arbitrary web script or HTML by editing a wiki page.

    • Update to 1:1.13.3-1
    Published Updated
  5. CVE-2008-0460

    Not ratedEPSS 14.56%Fix available

    CVE-2008-0460

    Cross-site scripting (XSS) vulnerability in api.php in (1) MediaWiki 1.11 through 1.11.0rc1, 1.10 through 1.10.2, 1.9 through 1.9.4, and 1.8; and (2) the BotQuery extension for MediaWiki 1.7 and earlier; when Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    • Update to 1:1.11.1-1
    Published Updated
  6. CVE-2007-4828

    Not ratedEPSS 1.32%Fix available

    CVE-2007-4828

    Cross-site scripting (XSS) vulnerability in the API pretty-printing mode in MediaWiki 1.8.0 through 1.8.4, 1.9.0 through 1.9.3, 1.10.0 through 1.10.1, and the 1.11 development versions before 1.11.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    • Update to 1.10.2-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →