p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 16

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 352

  1. CVE-2007-3238

    Not ratedEPSS 2%Fix available

    CVE-2007-3238

    Cross-site scripting (XSS) vulnerability in functions.php in the default theme in WordPress 2.2 allows remote authenticated administrators to inject arbitrary web script or HTML via the PATH_INFO (REQUEST_URI) to wp-admin/themes.php, a different vulnerability than CVE-2007-1622. NOTE: this might not cross privilege boundaries in some configurations, since the Administrator role has the unfiltered_html capability.

    • Update to 2.2.2-1
    Published Updated
  2. CVE-2007-1732

    Not ratedEPSS 1.59%Fix available

    CVE-2007-1732

    Cross-site scripting (XSS) vulnerability in an mt import in wp-admin/admin.php in WordPress 2.1.2 allows remote authenticated administrators to inject arbitrary web script or HTML via the demo parameter. NOTE: the provenance of this information is unknown; the details are obtained solely from third party information. NOTE: another researcher disputes this issue, stating that this is legitimate functionality for administrators. However, it has been patched by at least one vendor

    • Update to 2.1.3-1
    Published Updated
  3. CVE-2007-1622

    Not ratedEPSS 5.96%Public exploitFix available

    CVE-2007-1622

    Cross-site scripting (XSS) vulnerability in wp-admin/vars.php in WordPress before 2.0.10 RC2, and before 2.1.3 RC2 in the 2.1 series, allows remote authenticated users with theme privileges to inject arbitrary web script or HTML via the PATH_INFO in the administration interface, related to loose regular expression processing of PHP_SELF.

    • Update to 2.1.3-1
    Published Updated
  4. CVE-2007-1244

    Not ratedEPSS 7.54%Public exploitFix available

    CVE-2007-1244

    Cross-site request forgery (CSRF) vulnerability in the AdminPanel in WordPress 2.1.1 and earlier allows remote attackers to perform privileged actions as administrators, as demonstrated using the delete action in wp-admin/post.php. NOTE: this issue can be leveraged to perform cross-site scripting (XSS) attacks and steal cookies via the post parameter.

    • Update to 2.1.2-1
    Published Updated
  5. CVE-2007-1049

    Not ratedEPSS 6.47%Public exploitFix available

    CVE-2007-1049

    Cross-site scripting (XSS) vulnerability in the wp_explain_nonce function in the nonce AYS functionality (wp-includes/functions.php) for WordPress 2.0 before 2.0.9 and 2.1 before 2.1.1 allows remote attackers to inject arbitrary web script or HTML via the file parameter to wp-admin/templates.php, and possibly other vectors involving the action variable.

    • Update to 2.1.1-1
    Published Updated
  6. CVE-2007-0541

    Not ratedEPSS 2.67%Fix available

    CVE-2007-0541

    WordPress allows remote attackers to determine the existence of arbitrary files, and possibly read portions of certain files, via pingback service calls with a source URI that corresponds to a local pathname, which triggers different fault codes for existing and non-existing files, and in certain configurations causes a brief file excerpt to be published as a blog comment.

    • Update to 2.1.0-1
    Published Updated
  7. CVE-2007-0262

    Not ratedEPSS 2.58%Fix available

    CVE-2007-0262

    WordPress 2.0.6, and 2.1Alpha 3 (SVN:4662), does not properly verify that the m parameter value has the string data type, which allows remote attackers to obtain sensitive information via an invalid m[] parameter, as demonstrated by obtaining the path, and obtaining certain SQL information such as the table prefix.

    • Update to 2.0.8-1
    Published Updated
  8. CVE-2007-0233

    Not ratedEPSS 11.69%Public exploitFix available

    CVE-2007-0233

    wp-trackback.php in WordPress 2.0.6 and earlier does not properly unset variables when the input data includes a numeric parameter with a value matching an alphanumeric parameter's hash value, which allows remote attackers to execute arbitrary SQL commands via the tb_id parameter. NOTE: it could be argued that this vulnerability is due to a bug in the unset PHP command (CVE-2006-3017) and the proper fix should be in PHP; if so, then this should not be treated as a vulnerability in WordPress.

    • Update to 2.1.0-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →