p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 15

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 352

  1. CVE-2008-0196

    Not ratedEPSS 3.42%Fix available

    CVE-2008-0196

    Multiple directory traversal vulnerabilities in WordPress 2.0.11 and earlier allow remote attackers to read arbitrary files via a .. (dot dot) in (1) the page parameter to certain PHP scripts under wp-admin/ or (2) the import parameter to wp-admin/admin.php, as demonstrated by discovering the full path via a request for the \..\..\wp-config pathname; and allow remote attackers to modify arbitrary files via a .. (dot dot) in the file parameter to wp-admin/templates.php.

    • Update to 2.3.3-1
    Published Updated
  2. CVE-2008-0194

    Not ratedEPSS 3.75%Fix available

    CVE-2008-0194

    Directory traversal vulnerability in wp-db-backup.php in WordPress 2.0.3 and earlier allows remote attackers to read arbitrary files, delete arbitrary files, and cause a denial of service via a .. (dot dot) in the backup parameter in a wp-db-backup.php action to wp-admin/edit.php. NOTE: this might be the same as CVE-2006-5705.1.

    • Update to 2.1.0-1
    Published Updated
  3. CVE-2007-6318

    Not ratedEPSS 9.16%Public exploitFix available

    CVE-2007-6318

    SQL injection vulnerability in wp-includes/query.php in WordPress 2.3.1 and earlier allows remote attackers to execute arbitrary SQL commands via the s parameter, when DB_CHARSET is set to (1) Big5, (2) GBK, or possibly other character set encodings that support a "\" in a multibyte character.

    • Update to 2.3.2-1
    Published Updated
  4. CVE-2007-4894

    Not ratedEPSS 3.64%Fix available

    CVE-2007-4894

    Multiple SQL injection vulnerabilities in Wordpress before 2.2.3 and Wordpress multi-user (MU) before 1.2.5a allow remote attackers to execute arbitrary SQL commands via the post_type parameter to the pingback.extensions.getPingbacks method in the XMLRPC interface, and other unspecified parameters related to "early database escaping" and missing validation of "query string like parameters."

    • Update to 2.2.3-1
    Published Updated
  5. CVE-2007-4893

    Not ratedEPSS 1.52%Fix available

    CVE-2007-4893

    wp-admin/admin-functions.php in Wordpress before 2.2.3 and Wordpress multi-user (MU) before 1.2.5a does not properly verify the unfiltered_html privilege, which allows remote attackers to conduct cross-site scripting (XSS) attacks via modified data to (1) post.php or (2) page.php with a no_filter field.

    • Update to 2.2.3-1
    Published Updated
  6. CVE-2007-4154

    Not ratedEPSS 1.9%Fix available

    CVE-2007-4154

    SQL injection vulnerability in options.php in WordPress 2.2.1 allows remote authenticated administrators to execute arbitrary SQL commands via the page_options parameter to (1) options-general.php, (2) options-writing.php, (3) options-reading.php, (4) options-discussion.php, (5) options-privacy.php, (6) options-permalink.php, (7) options-misc.php, and possibly other unspecified components.

    • Update to 2.2.2-1
    Published Updated
  7. CVE-2007-4153

    Not ratedEPSS 2.08%Fix available

    CVE-2007-4153

    Multiple cross-site scripting (XSS) vulnerabilities in WordPress 2.2.1 allow remote authenticated administrators to inject arbitrary web script or HTML via (1) the Options Database Table in the Admin Panel, accessed through options.php; or (2) the opml_url parameter to link-import.php. NOTE: this might not cross privilege boundaries in some configurations, since the Administrator role has the unfiltered_html capability.

    • Update to 2.2.2-1
    Published Updated
  8. CVE-2007-3639

    Not ratedEPSS 2.39%Fix available

    CVE-2007-3639

    WordPress before 2.2.2 allows remote attackers to redirect visitors to other websites and potentially obtain sensitive information via (1) the _wp_http_referer parameter to wp-pass.php, related to the wp_get_referer function in wp-includes/functions.php; and possibly other vectors related to (2) wp-includes/pluggable.php and (3) the wp_nonce_ays function in wp-includes/functions.php.

    • Update to 2.2.2-1
    Published Updated
  9. CVE-2007-3544

    Not ratedEPSS 1.77%Fix available

    CVE-2007-3544

    Unrestricted file upload vulnerability in (1) wp-app.php and (2) app.php in WordPress 2.2.1 and WordPress MU 1.2.3 allows remote authenticated users to upload and execute arbitrary PHP code via unspecified vectors, possibly related to the wp_postmeta table and the use of custom fields in normal (non-attachment) posts. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2007-3543.

    • Update to 2.2.2-1
    Published Updated
  10. CVE-2007-3543

    Not ratedEPSS 1.65%Fix available

    CVE-2007-3543

    Unrestricted file upload vulnerability in WordPress before 2.2.1 and WordPress MU before 1.2.3 allows remote authenticated users to upload and execute arbitrary PHP code by making a post that specifies a .php filename in the _wp_attached_file metadata field; and then sending this file's content, along with its post_ID value, to (1) wp-app.php or (2) app.php.

    • Update to 2.2.1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →