p PatchFirst

PatchFirst · Latest vulnerabilities

spip vulnerabilities · Page 2

Vulnerability published for spip in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 78

  1. CVE-2025-71242

    Medium · CVSS 5.3EPSS 0.44%Fix available

    SPIP < 4.3.6 Authorization Bypass Leading to Content Disclosure

    SPIP before 4.3.6, 4.2.17, and 4.1.20 allows unauthorized content disclosure in the private area. The application does not properly check authorization when displaying content of articles and sections (rubriques) in AJAX-loaded fragments, allowing an authenticated attacker to access restricted content. This vulnerability is not mitigated by the SPIP security screen.

    • Update to 4.3.6+dfsg-1
    Published Updated
  2. CVE-2025-71241

    Medium · CVSS 4.8EPSS 0.34%Fix available

    SPIP < 4.3.6 Cross-Site Scripting in Private Area

    SPIP before 4.3.6, 4.2.17, and 4.1.20 allows Cross-Site Scripting (XSS) in the private area. The content of the error message displayed by the 'transmettre' API is not properly sanitized, allowing an attacker to inject malicious scripts. This vulnerability is mitigated by the SPIP security screen.

    • Update to 4.3.6+dfsg-1
    Published Updated
  3. CVE-2025-71240

    Medium · CVSS 4.8EPSS 0.2%Fix available

    SPIP < 4.2.15 Cross-Site Scripting via Code Tags

    SPIP before 4.2.15 allows Cross-Site Scripting (XSS) via crafted content in HTML code tags. The application does not properly verify JavaScript within code tags, allowing an attacker to inject malicious scripts that execute in a victim's browser.

    • Update to 4.3.0+dfsg-1
    Published Updated
  4. CVE-2023-53900

    Medium · CVSS 4.8EPSS 0.32%No fix published

    Spip 4.1.10 Admin Account Spoofing via Malicious SVG Upload

    Spip 4.1.10 contains a file upload vulnerability that allows attackers to upload malicious SVG files with embedded external links. Attackers can trick administrators into clicking a crafted SVG logo that redirects to a potentially dangerous URL through improper file upload filtering.

    Published Updated
  5. CVE-2024-8517

    Critical · CVSS 9.8EPSS 94.61%Public exploitFix available

    SPIP Bigup Multipart File Upload OS Command Injection

    SPIP before 4.3.2, 4.2.16, and 4.1.18 is vulnerable to a command injection issue. A remote and unauthenticated attacker can execute arbitrary operating system commands by sending a crafted multipart file upload HTTP request.

    • Update to 4.3.2+dfsg-1
    Published Updated
  6. CVE-2024-7954

    Critical · CVSS 9.8EPSS 90.05%Public exploitFix available

    SPIP porte_plume Plugin Arbitrary PHP Execution

    The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

    • Update to 4.3.0+dfsg-1
    Published Updated
  7. CVE-2021-44123

    High · CVSS 8.8EPSS 2.4%Fix available

    CVE-2021-44123

    SPIP 4.0.0 is affected by a remote command execution vulnerability. To exploit the vulnerability, an attacker must craft a malicious picture with a double extension, upload it and then click on it to execute it.

    • Update to 3.2.12-1
    Published Updated
  8. CVE-2021-44122

    High · CVSS 8.8EPSS 0.49%Fix available

    CVE-2021-44122

    SPIP 4.0.0 is affected by a Cross Site Request Forgery (CSRF) vulnerability in ecrire/public/aiguiller.php, ecrire/public/balises.php, ecrire/balise/formulaire_.php. To exploit the vulnerability, a visitor must visit a malicious website which redirects to the SPIP website. It is also possible to combine XSS vulnerabilities in SPIP 4.0.0 to exploit it. The vulnerability allows an authenticated attacker to execute malicious code without the knowledge of the user on the website (CSRF).

    • Update to 3.2.12-1
    Published Updated
  9. CVE-2021-44120

    Medium · CVSS 5.4EPSS 0.67%Fix available

    CVE-2021-44120

    SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability in ecrire/public/interfaces.php, adding the function safehtml to the vulnerable fields. An editor is able to modify his personal information. If the editor has an article written and available, when a user goes to the public site and wants to read the author's information, the malicious code will be executed. The "Who are you" and "Website Name" fields are vulnerable.

    • Update to 3.2.12-1
    Published Updated
  10. CVE-2021-44118

    Medium · CVSS 5.4EPSS 0.77%Fix available

    CVE-2021-44118

    SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).

    • Update to 3.2.12-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →