p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 7

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 353

  1. CVE-2017-1001000

    High · CVSS 7.5EPSS 84.94%Public exploitFix available

    CVE-2017-1001000

    The register_routes function in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in the REST API in WordPress 4.7.x before 4.7.2 does not require an integer identifier, which allows remote attackers to modify arbitrary pages via a request for wp-json/wp/v2/posts followed by a numeric value and a non-numeric value, as demonstrated by the wp-json/wp/v2/posts/123?id=123helloworld URI.

    • Update to 4.7.2+dfsg-1
    Published Updated
  2. CVE-2017-6814

    Medium · CVSS 5.4EPSS 2.87%Fix available

    CVE-2017-6814

    In WordPress before 4.7.3, there is authenticated Cross-Site Scripting (XSS) via Media File Metadata. This is demonstrated by both (1) mishandling of the playlist shortcode in the wp_playlist_shortcode function in wp-includes/media.php and (2) mishandling of meta information in the renderTracks function in wp-includes/js/mediaelement/wp-playlist.js.

    • Update to 4.7.3+dfsg-1
    Published Updated
  3. CVE-2016-6897

    Medium · CVSS 6.5EPSS 28.82%Public exploitFix available

    CVE-2016-6897

    Cross-site request forgery (CSRF) vulnerability in the wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPress before 4.6 allows remote attackers to hijack the authentication of subscribers for /dev/random read operations by leveraging a late call to the check_ajax_referer function, a related issue to CVE-2016-6896.

    • Update to 4.6.1+dfsg-1
    Published Updated
  4. CVE-2016-6896

    High · CVSS 7.1EPSS 38.07%Public exploitFix available

    CVE-2016-6896

    Directory traversal vulnerability in the wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPress 4.5.3 allows remote authenticated users to cause a denial of service or read certain text files via a .. (dot dot) in the plugin parameter to wp-admin/admin-ajax.php, as demonstrated by /dev/random read operations that deplete the entropy pool.

    • Update to 4.6.1+dfsg-1
    Published Updated
  5. CVE-2016-10148

    Medium · CVSS 4.3EPSS 1.64%Fix available

    CVE-2016-10148

    The wp_ajax_update_plugin function in wp-admin/includes/ajax-actions.php in WordPress before 4.6 makes a get_plugin_data call before checking the update_plugins capability, which allows remote authenticated users to bypass intended read-access restrictions via the plugin parameter to wp-admin/admin-ajax.php, a related issue to CVE-2016-6896.

    • Update to 4.6.1+dfsg-1
    Published Updated
  6. CVE-2017-5492

    High · CVSS 8.8EPSS 1.91%Fix available

    CVE-2017-5492

    Cross-site request forgery (CSRF) vulnerability in the widget-editing accessibility-mode feature in WordPress before 4.7.1 allows remote attackers to hijack the authentication of unspecified victims for requests that perform a widgets-access action, related to wp-admin/includes/class-wp-screen.php and wp-admin/widgets.php.

    • Update to 4.7.1+dfsg-1
    Published Updated
  7. CVE-2017-5490

    Medium · CVSS 6.1EPSS 2.44%Fix available

    CVE-2017-5490

    Cross-site scripting (XSS) vulnerability in the theme-name fallback functionality in wp-includes/class-wp-theme.php in WordPress before 4.7.1 allows remote attackers to inject arbitrary web script or HTML via a crafted directory name of a theme, related to wp-admin/includes/class-theme-installer-skin.php.

    • Update to 4.7.1+dfsg-1
    Published Updated
  8. CVE-2017-5487

    Medium · CVSS 5.3EPSS 87.3%Public exploitFix available

    CVE-2017-5487

    wp-includes/rest-api/endpoints/class-wp-rest-users-controller.php in the REST API implementation in WordPress 4.7 before 4.7.1 does not properly restrict listings of post authors, which allows remote attackers to obtain sensitive information via a wp-json/wp/v2/users request.

    • Update to 4.7.1+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →