p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 17

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 353

  1. CVE-2007-0233

    Not ratedEPSS 11.69%Public exploitFix available

    CVE-2007-0233

    wp-trackback.php in WordPress 2.0.6 and earlier does not properly unset variables when the input data includes a numeric parameter with a value matching an alphanumeric parameter's hash value, which allows remote attackers to execute arbitrary SQL commands via the tb_id parameter. NOTE: it could be argued that this vulnerability is due to a bug in the unset PHP command (CVE-2006-3017) and the proper fix should be in PHP; if so, then this should not be treated as a vulnerability in WordPress.

    • Update to 2.1.0-1
    Published Updated
  2. CVE-2007-0107

    Not ratedEPSS 11.71%Public exploitFix available

    CVE-2007-0107

    WordPress before 2.0.6, when mbstring is enabled for PHP, decodes alternate character sets after escaping the SQL query, which allows remote attackers to bypass SQL injection protection schemes and execute arbitrary SQL commands via multibyte charsets, as demonstrated using UTF-7.

    • Update to 2.0.6-1
    Published Updated
  3. CVE-2007-0106

    Not ratedEPSS 3.01%Fix available

    CVE-2007-0106

    Cross-site scripting (XSS) vulnerability in the CSRF protection scheme in WordPress before 2.0.6 allows remote attackers to inject arbitrary web script or HTML via a CSRF attack with an invalid token and quote characters or HTML tags in URL variable names, which are not properly handled when WordPress generates a new link to verify the request.

    • Update to 2.0.6-1
    Published Updated
  4. CVE-2006-6808

    Not ratedEPSS 6.88%Public exploitFix available

    CVE-2006-6808

    Cross-site scripting (XSS) vulnerability in wp-admin/templates.php in WordPress 2.0.5 allows remote attackers to inject arbitrary web script or HTML via the file parameter. NOTE: some sources have reported this as a vulnerability in the get_file_description function in wp-admin/admin-functions.php.

    • Update to 2.0.6-1
    Published Updated
  5. CVE-2006-6017

    Medium · CVSS 6.5EPSS 2.34%Fix available

    CVE-2006-6017

    WordPress before 2.0.5 does not properly store a profile containing a string representation of a serialized object, which allows remote authenticated users to cause a denial of service (application crash) via a string that represents a (1) malformed or (2) large serialized object, because the object triggers automatic unserialization for display.

    • Update to 2.0.5-0.1
    Published Updated
  6. CVE-2006-4743

    Not ratedEPSS 2.52%Fix available

    CVE-2006-4743

    WordPress 2.0.2 through 2.0.5 allows remote attackers to obtain sensitive information via a direct request for (1) 404.php, (2) akismet.php, (3) archive.php, (4) archives.php, (5) attachment.php, (6) blogger.php, (7) comments.php, (8) comments-popup.php, (9) dotclear.php, (10) footer.php, (11) functions.php, (12) header.php, (13) hello.php, (14) wp-content/themes/default/index.php, (15) links.php, (16) livejournal.php, (17) mt.php, (18) page.php, (19) rss.php, (20) searchform.php, (21) search.php, (22) sidebar.php, (23) single.php, (24) textpattern.php, (25) upgrade-functions.php, (26) upgrade-schema.php, or (27) wp-db-backup.php, which revea

    • Update to 2.0.5-0.1
    Published Updated
  7. CVE-2006-4028

    Not ratedEPSS 3.75%Fix available

    CVE-2006-4028

    Multiple unspecified vulnerabilities in WordPress before 2.0.4 have unknown impact and remote attack vectors. NOTE: due to lack of details, it is not clear how these issues are different from CVE-2006-3389 and CVE-2006-3390, although it is likely that 2.0.4 addresses an unspecified issue related to "Anyone can register" functionality (user registration for guests).

    • Update to 2.0.4-1
    Published Updated
  8. CVE-2006-3389

    Not ratedEPSS 2.94%Fix available

    CVE-2006-3389

    index.php in WordPress 2.0.3 allows remote attackers to obtain sensitive information, such as SQL table prefixes, via an invalid paged parameter, which displays the information in an SQL error message. NOTE: this issue has been disputed by a third party who states that the issue does not leak any target-specific information.

    • Update to 2.0.4-1
    Published Updated
  9. CVE-2006-2667

    Not ratedEPSS 14.53%Public exploitFix available

    CVE-2006-2667

    Direct static code injection vulnerability in WordPress 2.0.2 and earlier allows remote attackers to execute arbitrary commands by inserting a carriage return and PHP code when updating a profile, which is appended after a special comment sequence into files in (1) wp-content/cache/userlogins/ (2) wp-content/cache/users/ which are later included by cache.php, as demonstrated using the displayname argument.

    • Update to 2.0.3-1
    Published Updated
  10. CVE-2006-1796

    Not ratedEPSS 1.99%Fix available

    CVE-2006-1796

    Cross-site scripting (XSS) vulnerability in the paging links functionality in template-functions-links.php in Wordpress 1.5.2, and possibly other versions before 2.0.1, allows remote attackers to inject arbitrary web script or HTML to Internet Explorer users via the request URI ($_SERVER['REQUEST_URI']).

    • Update to 2.0.1
    Published Updated
  11. CVE-2006-0986

    Not ratedEPSS 3.28%Fix available

    CVE-2006-0986

    WordPress 2.0.1 and earlier allows remote attackers to obtain sensitive information via a direct request to (1) default-filters.php, (2) template-loader.php, (3) rss-functions.php, (4) locale.php, (5) wp-db.php, and (6) kses.php in the wp-includes/ directory; and (7) edit-form-advanced.php, (8) admin-functions.php, (9) edit-link-form.php, (10) edit-page-form.php, (11) admin-footer.php, and (12) menu.php in the wp-admin directory; and possibly (13) list directory contents of the wp-includes directory. NOTE: the vars.php, edit-form.php, wp-settings.php, and edit-form-comment.php vectors are already covered by CVE-2005-4463. The menu-header.ph

    • Update to 2.0.2-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →