p PatchFirst

PatchFirst · Latest vulnerabilities

wordpress vulnerabilities · Page 14

Vulnerability published for wordpress in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 351

  1. CVE-2009-2336

    Not ratedEPSS 5.41%Fix available

    CVE-2009-2336

    The forgotten mail interface in WordPress and WordPress MU before 2.8.1 exhibits different behavior for a password request depending on whether the user account exists, which allows remote attackers to enumerate valid usernames. NOTE: the vendor reportedly disputes the significance of this issue, indicating that the behavior exists for "user convenience."

    • Update to 2.8.3-1
    Published Updated
  2. CVE-2009-2335

    Not ratedEPSS 85%Public exploitFix available

    CVE-2009-2335

    WordPress and WordPress MU before 2.8.1 exhibit different behavior for a failed login attempt depending on whether the user account exists, which allows remote attackers to enumerate valid usernames. NOTE: the vendor reportedly disputes the significance of this issue, indicating that the behavior exists for "user convenience."

    • Update to 2.8.3-1
    Published Updated
  3. CVE-2009-2334

    Not ratedEPSS 6.26%Public exploitFix available

    CVE-2009-2334

    wp-admin/admin.php in WordPress and WordPress MU before 2.8.1 does not require administrative authentication to access the configuration of a plugin, which allows remote attackers to specify a configuration file in the page parameter to obtain sensitive information or modify this file, as demonstrated by the (1) collapsing-archives/options.txt, (2) akismet/readme.txt, (3) related-ways-to-take-action/options.php, (4) wp-security-scan/securityscan.php, and (5) wp-ids/ids-admin.php files. NOTE: this can be leveraged for cross-site scripting (XSS) and denial of service.

    • Update to 2.8.3-1
    Published Updated
  4. CVE-2008-5695

    Not ratedEPSS 12.01%Public exploitFix available

    CVE-2008-5695

    wp-admin/options.php in WordPress MU before 1.3.2, and WordPress 2.3.2 and earlier, does not properly validate requests to update an option, which allows remote authenticated users with manage_options and upload_files capabilities to execute arbitrary code by uploading a PHP script and adding this script's pathname to active_plugins.

    • Update to 2.3.2
    Published Updated
  5. CVE-2008-5113

    Not ratedEPSS 1.36%Fix available

    CVE-2008-5113

    WordPress 2.6.3 relies on the REQUEST superglobal array in certain dangerous situations, which makes it easier for remote attackers to conduct delayed and persistent cross-site request forgery (CSRF) attacks via crafted cookies, as demonstrated by attacks that (1) delete user accounts or (2) cause a denial of service (loss of application access). NOTE: this issue relies on the presence of an independent vulnerability that allows cookie injection.

    • Update to 2.5.1-10
    Published Updated
  6. CVE-2008-4796

    Not ratedEPSS 8.98%Fix available

    CVE-2008-4796

    The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

    • Update to 2.5.1-9
    Published Updated
  7. CVE-2008-4769

    Not ratedEPSS 8.97%Public exploitFix available

    CVE-2008-4769

    Directory traversal vulnerability in the get_category_template function in wp-includes/theme.php in WordPress 2.3.3 and earlier, and 2.5, allows remote attackers to include and possibly execute arbitrary PHP files via the cat parameter in index.php. NOTE: some of these details are obtained from third party information.

    • Update to 2.5.1-1
    Published Updated
  8. CVE-2008-4106

    Not ratedEPSS 5.48%Fix available

    CVE-2008-4106

    WordPress before 2.6.2 does not properly handle MySQL warnings about insertion of username strings that exceed the maximum column width of the user_login column, and does not properly handle space characters when comparing usernames, which allows remote attackers to change an arbitrary user's password to a random value by registering a similar username and then requesting a password reset, related to a "SQL column truncation vulnerability." NOTE: the attacker can discover the random password by also exploiting CVE-2008-4107.

    • Update to 2.5.1-8
    Published Updated
  9. CVE-2008-1930

    Not ratedEPSS 5.04%Fix available

    CVE-2008-1930

    The cookie authentication method in WordPress 2.5 relies on a hash of a concatenated string containing USERNAME and EXPIRY_TIME, which allows remote attackers to forge cookies by registering a username that results in the same concatenated string, as demonstrated by registering usernames beginning with "admin" to obtain administrator privileges, aka a "cryptographic splicing" issue. NOTE: this vulnerability exists because of an incomplete fix for CVE-2007-6013.

    • Update to 2.5.1-1
    Published Updated
  10. CVE-2008-1502

    Not ratedEPSS 10.5%Fix available

    CVE-2008-1502

    The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

    • Update to 2.5.0-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →