p PatchFirst

PatchFirst · Latest vulnerabilities

moodle/moodle vulnerabilities · Page 22

Vulnerabilities published for moodle/moodle in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 437

  1. CVE-2011-4301

    Not ratedEPSS 2.1%Fix available

    CVE-2011-4301

    The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

    • Update to 1.9.14
    • Update to 2.0.5
    • Update to 2.1.2
    Published Updated
  2. CVE-2011-4203

    Not ratedEPSS 1.18%Fix available

    CVE-2011-4203

    CRLF injection vulnerability in calendar/set.php in the Calendar component in Moodle 1.9.x before 1.9.15, 2.0.x before 2.0.6, 2.1.x before 2.1.3, and 2.2 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via vectors involving the url variable.

    • Update to 1.9.15
    • Update to 2.0.6
    • Update to 2.1.3
    Published Updated
  3. CVE-2010-1619

    Medium · CVSS 5.3EPSS 1.67%Fix available

    CVE-2010-1619

    Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

    • Update to 1.8.12
    • Update to 1.9.8
    Published Updated
  4. CVE-2010-1618

    Not ratedEPSS 1.81%Fix available

    CVE-2010-1618

    Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

    • Update to 1.8.12
    • Update to 1.9.8
    Published Updated
  5. CVE-2010-1615

    Critical · CVSS 9.3EPSS 1.72%Fix available

    CVE-2010-1615

    Multiple SQL injection vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to execute arbitrary SQL commands via vectors related to (1) the add_to_log function in mod/wiki/view.php in the wiki module, or (2) "data validation in some forms elements" related to lib/form/selectgroups.php.

    • Update to 1.8.12
    • Update to 1.9.8
    Published Updated
  6. CVE-2010-1614

    Medium · CVSS 5.3EPSS 1.67%Fix available

    CVE-2010-1614

    Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.

    • Update to 1.8.12
    • Update to 1.9.8
    Published Updated
  7. CVE-2008-5153

    Not ratedEPSS 0.39%Fix available

    CVE-2008-5153

    spell-check-logic.cgi in Moodle 1.8.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.

    • Update to 1.6.9
    • Update to 1.7.7
    • Update to 1.8.8
    • Update to 1.9.4
    Published Updated
  8. CVE-2008-1502

    Not ratedEPSS 10.5%Fix available

    CVE-2008-1502

    The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

    • Update to 1.8.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →